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1 MultiSim
1.1 Running Windows Programs Using Mac

• Obtain free Microsoft Windows from:
http://software.tamu.edu

• Set up a Windows partition on your Mac:
https://support.apple.com/en-us/HT204009

• Install Windows on your Mac with Boot Camp:
https://support.apple.com/en-us/HT201468

1.2 Installation
• Purchase (at zero cost) ”LabVIEW System Design” and ”Circuit Design Suite Pro” from:

http://software.tamu.edu

• Follow the installation instructions you receive by email

• Use your TAMU email when creating your NI account

• Make sure you install LabView BEFORE you install MultiSim

1.3 Online Access through VOAL
• Using a web browser, go to https://connect.voal.tamu.edu

Figure 1: TAMU VOAL web page

• Click on ”VMware Horizon Web Access” and login using your TAMU NetID and password (Fig. 1)
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• Click on ”NI MultiSim” on the next page (Fig. 2)

Figure 2: VMware Horizon Web Portal

• Alternatively, you can download and install VMware Horizon Client (see Fig. 1) to your PC, but you will still
need internet connection to run MultiSim.

1.4 Schematics Editor
• Open the schematics Editor (Start→ NI MultiSim 14.1)

• Insert components using the buttons in Fig. 3

Run

Place Source

Place Basic

Place Diode

Place Transistor

Place Analog Select Active Analysis

Figure 3: MultiSim schematic editor buttons
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– Place Source: Voltage and current sources

– Place Basic: Resistors, capacitors, and other basic components

– Place Analog: Opamps and other analog circuit blocks

– Place Diode: Diodes

– Place Transistor: Transistors

• To connect two terminals, left click on one terminal, then the other one. Alternatively, use ”Place → Wire”
from the main menu.

• Double click on the wires to label them. After writing the net name, check ”Show net name”, then click ”OK”.

1.5 Adding User Database (CD4007N, CD4007P and 2N7000G Transistors)
• Download the file ”UsrComp S ECEN.usr” to a folder

• Click on Options→ Global Options

Figure 4: MultiSim global options

• In the Global Options window (see Fig.4), click on ”User database”, then click on

• Find the file ”UsrComp S ECEN.usr”, click on ”Open”, then ”OK”

• Click on ”Place transistor” in Fig. 3

• Select ”User Database” on the top left corner

• Place MOS→ CD4007N, CD4007P and 2N7000G
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1.6 Bode Plots (AC Simulation)
• Click on ”Select Active Analysis” in Fig. 3, then click on ”AC Sweep” (Fig. 11)

Figure 5: AC simulation setup

• On the ”Frequency Parameters” tab, select:

– Start frequency (FSTART): 1 Hz
– Stop frequency (FSTOP): 10 MHz
– Sweep type: Decade
– Number of points: 100
– Vertical scale: Decibel

• On the ”Output” tab, click on ”V(Vo)”, then ”Add”, then ”Save”

• Click on ”Run” in Fig. 3

1.7 Time-Domain Waveforms (Transient Simulation)
• Click on ”Select Active Analysis” in Fig. 3, then click on ”Transient” (Fig. 6)

Figure 6: Transient simulation setup
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• Calculate T = 1/fi , where fi is the input frequency

• On the ”Analysis Parameters” tab, select:

– Start time (TSTART): 0

– End time (TSTOP): 10T

– Check ”Maximum time step (TMAX)” and enter the value:
T

100

• On the ”Output” tab, click on ”V(Vi)” and ”V(Vo)”, then ”Add”, then ”Save”

• Click on ”Run” in Fig. 3

1.8 Total Harmonic Distortion (Fourier Simulation)
• Click on ”Select Active Analysis” in Fig. 3, then click on ”Fourier” (Fig. 7)

Figure 7: Fourier simulation setup

• Calculate T = 1/fi , where fi is the input frequency, and set N = 9

• On the ”Analysis Parameters” tab, select:

– Frequency resolution (fundamental frequency): fi
– Number of harmonics: N

– Stop time for sampling (TSTOP): 10T

• Click on ”Edit transient analysis”, select:

– Start time (TSTART): 0

– End time (TSTOP): 10T

– Check ”Maximum time step (TMAX)” and enter the value:
T

100(N + 1)

• On the ”Output” tab, click on ”V(Vo)”, then ”Add”, then ”Save”

• Click on ”Run” in Fig. 3
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1.9 Input Resistance (AC Simulation)
• Identify the label of the input voltage source: V1 in Fig. 8(a)

• Make sure that the ”AC analysis magnitude” of V1 is set to 1 as in Fig. 8(b)
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Figure 8: (a) Amplifier circuit for Ri simulation (b) Input voltage source properties

• Click on ”Select Active Analysis” in Fig. 3, then click on ”AC Sweep” (Fig. 11)

Figure 9: AC simulation setup for input resistance

• On the ”Frequency Parameters” tab, select:

– Start frequency (FSTART): 1 Hz

– Stop frequency (FSTOP): 10 MHz

– Sweep type: Decade

– Number of points: 100

– Vertical scale: Linear

• On the ”Output” tab, click on ”Add expression...”, type ”1/I(V1)”, then click on ”OK” and ”Save”

• Click on ”Run” in Fig. 3

• Magnitude of 1/I(V1) is the input resistance Ri
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1.10 Output Resistance (AC Simulation)
• Remove the input voltage source, insert an AC current source and connect it to the Vo node as in Fig. 10(a)

• Make sure that the ”AC analysis magnitude” of the AC current source is set to 1 as in Fig. 10(b)
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Figure 10: (a) Amplifier circuit for Ro simulation (b) AC current source properties

• Click on ”Select Active Analysis” in Fig. 3, then click on ”AC Sweep” (Fig. 11)

Figure 11: AC simulation setup for output resistance

• On the ”Frequency Parameters” tab, select:

– Start frequency (FSTART): 1 Hz

– Stop frequency (FSTOP): 10 MHz

– Sweep type: Decade

– Number of points: 100

– Vertical scale: Linear

• On the ”Output” tab, click on ”V(Vo)”, then ”Add”, then ”Save”

• Click on ”Run” in Fig. 3

• Magnitude of V(Vo) is the output resistance Ro
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1.11 Parameter Sweep
• From the Schematic Editor, click on ”View”→ ”Circuit Parameters”

– In the Circuit Parameters panel (bottom right corner), click on ”Add parameter” button:
– Enter the name and value of the parameter
– Use the parameter in the circuit for the variable to be swept

• Click on ”Select Active Analysis” in Fig. 3, then click on ”Parameter Sweep” (Fig. 12)

Figure 12: Parameter sweep setup

• On the ”Analysis Parameters” tab, select:

– Sweep Parameter: Circuit parameter
– Parameter: Choose from the list
– Enter the sweep type, start, stop and increment
– Choose the ”Analysis to Sweep”
– Click on ”Edit Analysis”, and enter the analysis parameters

• On the ”Output” tab, click on ”V(Vo)”, then ”Add”, then ”Save”

• Click on ”Run” in Fig. 3

1.12 Grapher View (Labeling Simulation Data at Specific Points)
• After running a simulation, grapher view window will show the plots. Fig. 13 shows the menu buttons.

Background

Cursors

Add data label at cursor

Figure 13: Grapher view menu buttons

– Use the ”Background” button to toggle background (use white background for screenshots)
– Click on ”Cursors” to measure simulated results, you can drag the cursors using the mouse
– Click on ”Add data label at cursor” to label simulated values at specific points
– You can obtain the screenshot using ”Snip & Sketch” in Windows
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2 Analog Discovery 2
2.1 Power Supplies

• Connect Analog Discovery 2 to your computer and run Waveforms

• Connect V+ to Positive Supply, V- to Negative Supply, to ground

• Click on ”Supplies”, set positive and negative supply voltages, then click on ”Master Enable”

2.2 Bode Plots (Network Measurement)
• Connect Analog Discovery 2 to your computer and run Waveforms

• Connect W1 and 1+ to Vi (input), 2+ to Vo (output), 1-, 2-, to ground

• Click on ”Network”, set ”Start” to 100Hz and ”Stop” to 1MHz

• Uncheck ”Channel 1” (Yellow Box)

• Make sure the value of input amplitude does not saturate the output

• Click on ”Single”, magnitude and phase Bode plots will be drawn as shown in Fig. 14

• Click on View→ Cursors

– Click on ”+Normal”, then ”+Delta”, then ”+Normal”
– Move Cursor 1 to the flat part of the magnitude plot, then move Cursor 2 such that C2 ∆Y is -3dB, so

that the frequency of Cursor 2 corresponds to 3dB frequency
– Move Cursor 3 to the specific input frequency (2kHz as an example) to measure the corresponding mag-

nitude and the phase

Magnitude at 2kHz Phase at 2kHz

Input

Amplitude

Unchecked

3−dB Frequency

Start Frequency Stop Frequency

Figure 14: Network Analyzer Window

9



2.3 Time-Domain Waveforms (Scope Measurement)
• Connect Analog Discovery 2 to your computer and run Waveforms

• Connect W1 and 1+ to Vi (input), 2+ to Vo (output), 1-, 2-, to ground

• Click on ”Wavegen”, enter the type, frequency and amplitude of the input waveform, and click on ”Run”

• Click on ”Welcome” tab, then on ”Scope”, then ”Run”

• Time-domain waveforms should appear on the Scope window as shown in Fig. 15

• You can click on ”Single” to hold the plot

• Click on View→ Cursors

– Click on ”+Normal”, then ”+Delta”, then ”+Normal” and ”+Normal”

– Move Cursor 1 and 2 to zero-crossings of the input and the output, respectively, and calculate the phase
difference from ∆t

– Move Cursors 3 and 4 to the maximum point of the input and the output, and calculate the magnitude
of the transfer function

Figure 15: Scope Window
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2.4 Total Harmonic Distortion (Spectrum Measurement)
• Connect Analog Discovery 2 to your computer and run Waveforms

• Connect W1 and 1+ to Vi (input), 2+ to Vo (output), 1-, 2-, to ground

• Click on ”Wavegen”, enter the type, frequency and amplitude of the input waveform, and click on ”Run”

• Click on ”Welcome” tab, then on ”Spectrum”, then ”Run”

• Output spectrum should appear on the Spectrum window as shown in Fig. 16

– Uncheck ”Trace 1” (Yellow Box)

– Set ”Stop” to (N + 1)fi , where fi is the input frequency and N is the number of harmonics

– Set ”Type” to ”Linear dB Average”

– Set ”Count” to 10

• Click on ”View”→ ”Measurements”, on the Measurements Panel:

– Click on ”Add”, then ”Trace 2”

– Expand the ”Dynamic” menu (click on the arrow)

– Click on ”THD”, then ”Add”, then ”Close”

• Total Harmonic Distortion (THD) in % can be found using the following formula:

THD in % = 10(THD in dBc)/20×100%

Stop Frequency

Type

Unchecked

THD in dBc

Count

Figure 16: Spectrum Window
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2.5 Input Resistance (Network Measurement)
• Connect Analog Discovery 2 to your computer and run Waveforms

• Insert a test resistor (Rtest) that is close to the calculated value of the input resistance Ri as in Fig. 17
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Figure 17: Amplifier setup for input resistance measurement

• Connect W1, 1+ and 2+ as shown in Fig. 17, 1-, 2-, to ground

• Click on ”Network”, set ”Start” to 100Hz and ”Stop” to 1MHz, uncheck ”Channel 1”

• Make sure that the amplifier is not saturated

• Click on ”Single”, magnitude and phase Bode plots will be drawn

• Measure the magnitude within the flat portion, which is equal to
Ri

Rtest + Ri
, then find Ri

2.6 Output Resistance (Network Measurement)
• Connect Analog Discovery 2 to your computer and run Waveforms

• Insert a test resistor (Rtest) that is close to the calculated value of the output resistance Ro as in Fig. 18
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Figure 18: Amplifier setup for output resistance measurement

• Connect W1, 1+ and 2+ as shown in Fig. 18, 1-, 2-, to ground

• Click on ”Network”, set ”Start” to 100Hz and ”Stop” to 1MHz, uncheck ”Channel 1”

• Make sure that the amplifier is not saturated

• Click on ”Single”, magnitude and phase Bode plots will be drawn

• Measure the magnitude within the flat portion, which is equal to
Ro

Rtest + Ro
, then find Ro
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3 Keysight MSO-X 3024T Oscilloscope
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Figure 19: Keysight MSO-X 3024T oscilloscope front view

3.1 Bode Plots (Frequency Response Analysis)
• Connect Gen Out and Channel 1 to Vi (input), Channel 2 to Vo (output)

• Make sure ”Touch” is activated, then touch the dropdown menu on the top left corner (see Fig. 19)

• Go to ”Applications” and select ”Frequency Response Analysis”, then touch ”Setup & Apply ...” (Fig. 20)

• Select your starting and stopping frequencies, points per decade, and input amplitude

• Make sure that the impedance is set to ”High-Z”, then touch ”Run Analysis”

Figure 20: Frequency response setup window
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• In the frequency response output window (Fig. 21), you can drag the triangles to use as cursors

Figure 21: Frequency response output window

3.2 Time-Domain Waveforms
• Connect Gen Out and Channel 1 to Vi (input), Channel 2 to Vo (output)

• Make sure ”Touch” is activated, then push the ”Wave Gen” button (see Fig. 19)

• Select your waveform, frequency, amplitude, and DC offset by touching the corresponding parameter (Fig. 22)

Figure 22: Scope window with waveform generator menu

• Push ”Auto Scale”

• Push the dials under each channel button to zero the waveform offset
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• Push ”Cursors”

• Touch ”Mode” and select ”Manual”

• Touch and drag the cursors (see Fig. 23) to measure phase difference in seconds.

Figure 23: Using cursors to measure phase difference in seconds

• To measure phase difference in degrees, touch ”Units”, then ”X Units Seconds”, and then ”Phase (o)” (see
Fig. 24)

Figure 24: Using cursors to measure phase difference in degrees
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3.3 Total Harmonic Distortion
• Connect Gen Out and Channel 1 to Vi (input), Channel 2 to Vo (output)

• Make sure ”Touch” is activated, then push the ”Math” button (see Fig. 19)

• Touch ”Operator” and select ”FFT (magnitude)”

• Make sure the source is selected as Channel 2

• If the touch options are ”Center” and ”Span”, change them to ”Start Freq” and ”Stop Freq”, and set their
values

• Make sure you display sufficient number of periods for accurate computation; the number of periods can be
adjusted by turning the ”Horizontal Dial” in Fig. 19

• Touch ”Display Math” and fill in the respective checkbox

• Touch the dropdown menu on the top right, next to ”Meas”

• Touch ”Measurements”, then ”Type”, then ”Total Harmonic Distortion”, and then ”Add Measurement”

Figure 25: Total harmonic distortion window
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3.4 Input Resistance (Frequency Response Analysis)
• Insert a test resistor (Rtest) that is close to the calculated value of the input resistance Ri as in Fig. 26
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Figure 26: Amplifier setup for input resistance measurement

• Connect Channel 1, Channel 2 and Wave Gen as shown in Fig. 26

• Make sure ”Touch” is activated, then touch the dropdown menu on the top left corner (see Fig. 19)

• Go to ”Applications” and select ”Frequency Response Analysis”, then touch ”Setup & Apply ...” (Fig. 20)

• Select your starting and stopping frequencies, points per decade, and input amplitude

• Make sure that the impedance is set to ”High-Z”, then touch ”Run Analysis”

• Measure the magnitude within the flat portion, which is equal to
Ri

Rtest + Ri
, then find Ri

3.5 Output Resistance (Frequency Response Analysis)
• Insert a test resistor (Rtest) that is close to the calculated value of the output resistance Ro as in Fig. 27
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Figure 27: Amplifier setup for output resistance measurement

• Connect Channel 1, Channel 2 and Wave Gen as shown in Fig. 27

• Make sure ”Touch” is activated, then touch the dropdown menu on the top left corner (see Fig. 19)

• Go to ”Applications” and select ”Frequency Response Analysis”, then touch ”Setup & Apply ...” (Fig. 20)

• Select your starting and stopping frequencies, points per decade, and input amplitude

• Make sure that the impedance is set to ”High-Z”, then touch ”Run Analysis”

• Measure the magnitude within the flat portion, which is equal to
Ro

Rtest + Ro
, then find Ro
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3.6 Exporting Data as an Excel (.csv) File
• Insert flash drive

• Push the ”Save/Recall” button

• Touch ”File Name” and enter the name

• Touch ”Save”

• Touch ”Format”

• Touch ”CSV data (*.csv)”

• Touch ”Press to go” and select the desired directory

• Touch ”Press to Save”

3.7 Taking a Screenshot (.png)
• Insert flash drive

• Push the ”Save/Recall” button

• Touch ”File Name” and enter the name

• Touch ”Save”

• Touch ”Format”

• Touch ”PNG 24-bit image (*png)”

• Touch ”Press to go” and select the desired directory

• Touch ”Press to Save”
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