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Lab 0: Introduction
This laboratory complements the course ELEN 474: VLSI Circuit Design. The lab
manual details basic CMOS analog integrated Circuit design, simulation, and testing
techniques. Several tools from the Cadence Development System have been integrated
into the lab to teach students the idea of computer aided design (CAD) and to make the
analog VLSI experience more practical.
To fully appreciate the material in this lab course, the student should have a
minimal background with the following computer systems, equipment, and circuit
analysis techniques. Students should be familiar with the UNIX operating system.
Previous experience using a SPICE-like circuit simulator is also important. This course
does not explain the various SPICE analyses and assumes the student is capable of
configuring the appropriate SPICE analysis to obtain the desired information from the
circuit. Finally, the student should have general familiarity with active circuit “hand”
analysis. All of these prerequisites are satisfied by having credit for ELEN 325 and
ELEN 326.
The lab manual develops the concepts of analog integrated circuit design in a
bottom-up approach. First, the basic devices of CMOS circuit design, the NMOS and
PMOS transistors, are introduced and characterized. Then, one or more transistors are
combined into a subcircuit such as a differential pair, current-mirror, or simple inverter
and these small circuits are analyzed. Finally, these subcircuits are connected to form
larger circuits such as operational transconductance amplifiers and operational amplifiers,
and the idea of design methodologies is developed. Continuing with the bottom-up
approach, these circuits can be combined to form systems such as filters or data
converters (not currently covered in this course). The following figure illustrates the
bottom-up approach used in the laboratory.
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Figure 0-1: Bottom-Up Approach
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The lab activities will generally be one week labs. However there will be some
longer labs toward the end that will be two week labs. Before the lab, the student should
read through the lab description and perform the pre-lab exercises. Generally, the pre-lab
exercises are the “hand” design for the circuit being studied. During the lab students will
perform circuit simulations to verify their hand calculations. Tweaking circuit
parameters will usually need to be done since hand calculations will not always be 100 %
accurate. Also, the integrated circuit layout will be created. This will often require more
time to do than 3 hour lab time that is allocated and will need to be finished outside of lab
sometime before the next lab meeting.
Lab Report
Each team will submit one lab report for each lab. Reports are due at the
beginning of class. Lab reports will consist of not more than three typed pages of singlespaced text. Be concise.
•

TITLE PAGE

•

DESCRIPTION
Include three or four sentences which describe the significant aspects of the lab.
This section specifies problems or theory that will be investigated or solved. The
description is a more detailed version of the objective.

•

DESIGN
Include circuit diagrams and design formulas/calculations. All circuit diagrams
must be descriptively titled and labeled. A design formula/calculation must be
given for each component. Do not derive equations.

•

RESULTS
This section usually consists of tables and SPICE plots.

•

DISCUSSION
This is the most important part of the lab report. Simply justify the difference
between the theoretical and simulated values and answer and needed questions.

•

CONCLUSION
Two or three sentence summary of what the lab demonstrated. The conclusion
usually responds to the problems specified in the DESCRIPTION section.
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Lab 1: Introduction to Cadence
Objectives
Learn how to login on a UNIX station, perform basic UNIX tasks, and use the
Cadence design system to simulate and layout simple circuits.
Introduction
This lab will introduce students to the computer system and software used
throughout the lab course. First, students will learn how to login and logout of a Sun
SparcStation. Next, basic operating system commands used to perform file management,
printing, and various other tasks will be illustrated. Finally, students will be given an
overview of the Cadence Development System.
In-class examples will demonstrate the creation of libraries, the construction of
schematic symbols, the drafting of schematics, and the layout of simple transistors. The
student will apply this knowledge to the creation of a CMOS inverter.
Logging-In/Logging-Out
In order to use the UNIX machines, you must first login to the system. As with
the PC lab, enter the logon id and password at the prompts. Login using the logon ID and
password obtained from the electrical engineering office. This is your account and all
files stored in this area will be retained by the system after logging-out. Do not insert a
floppy disk in the SparcStation. There is no need to attempt to make floppy disk backups of your data files.
Using the UNIX Operating System
Using the UNIX operating system is similar to using other operating systems such
as DOS. UNIX commands are issued to the system by typing them in a “shell” or
“xterm”. UNIX commands are case sensitive so be careful when issuing a command,
usually they are given in lower-case.
The following list summarizes all the basic commands required to manage the
data files you will be creating in this lab course. All UNIX commands are entered from
the shell or xterm window. Do not use UNIX commands for modifying, deleting, or
moving any Cadence data files.

3

Table 1-1: Common UNIX Commands
ls [–la]

Lists files in the current directory. ”l” lists with properties and
“a” also lists hidden files (ones beginning with a “.”).
cd XXXX
Changes the current directory to XXXX.
cd ..
Changes the current directory back one level.
cp XXXX YYYY
Copies the file XXXX to YYYY.
mv XXXX YYYY
Move file XXXX to YYYY. Also used for rename
rm XXXX
Deletes the file XXXX
mkdir XXXX
Creates the directory XXXX.
lp -dXXXX YYYY
Prints the textfile or postscript file YYYY to the printer named
XXXX, where XXXX can be either “ipszac” or “hpszac”.
gedit XXXX&
Starts the gedit text editor program and loads file XXXX.
icfb &
Starts the Cadence software.
top
Check available processes and memory usage.
quota –v
Check for disk space available
who|grep my_name
Display the terminal where I am connected
Note: The command “&” tells UNIX to execute the command and return the prompt to
the active shell.
Cadence
The Cadence Development System consists of a bundle of software packages
such as schematic editors, simulators, and layout editors. This software manages the
development process for analog, digital, and mixed-mode circuits. In this course, we will
strictly use the tools associated with analog circuit design.
All the Cadence design tools are managed by a software package called the
Design Framework II. This program supervises a common database which holds all
circuit information including schematics, layouts, and simulation data.
From the Design Framework II also known as the "framework", we can invoke a
program called the Library Manager which governs the storage of circuit data. We can
access libraries and the components of the libraries called cells.
Also, from the framework we can invoke the schematic entry editor called
"Composer". Composer is used to draw circuit diagrams and draw circuit symbols.
A program called "Virtuoso" is used for creating integrated circuit layouts. The
layout is used to create the masks which are used in the integrated circuit fabrication
process.
Finally, circuit simulation is handled through an interface called "Analog Artist."
This interface can be used to invoke various simulators including HSPICE, Spectre, and
Verilog. We will be using the SpectreS simulator in this course.
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Starting Cadence for the First Time (Linux Machines in 213A):
To access one of the lab machines from external machines: (this step is not
required from in the lab)
Open a Terminal window and type
ssh –X LinAA-213A
(replace AA with a number from 01 to 20, the X must be capital)

Type in your password
Accessing Cadence, First time:
mkdir cadencelin
cd cadencelin
/softwares/setup/cadence/ncsu

Starting Cadence for the First Time (On a Unix Machine, this is a secondary
method and should only be used outside of the lab)
All Cadence simulations need to be run on the Sunfire server. To connect to this server,
you should type the following commands into a terminal:
ssh –X sunfire.ece.tamu.edu
DO NOT CLOSE THE TERMINAL. It must remain open the whole time you have
Cadence running.
Before Cadence can be run, some basic configuration of your system needs to be done.
We need to first edit our .cshrc file so that the correct version of cadence is run. You can
do this with any text editor that you wish. If you are new to UNIX, I recommend a
program called “gedit” since it is very similar to Notepad in Windows. From a terminal
type:
cd
gedit .cshrc &

In the text editor that opens, you need to add the following two lines to the end of the file:
source /usr/local/bin/setup.ic5141
setenv CDK_DIR /baby/cadence/ic50/local

Save the changes you made to .cshrc and close the file. At the terminal type:
source .cshrc
Next, edit your .cdsenv file.
cd
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gedit .cdsenv
Add the line:
asimenv.startup cds_ade_wftool string “awd”
Next we need to make a new directory called “cadence” which will hold all of our
cadence files. This will also be the directory you need to run Cadence from in the future.
In this folder we will also put two more configuration files, cds.lib and .cdsinit.
mkdir cadence
cd cadence

cp /baby/courses/474/cds.lib ~/cadence

cp /baby/courses/474/.cdsinit ~/cadence
Cadence should be ready to run now. From now on, you can launch Cadence when you
login to Sunfire by typing
cd cadence
icfb &

This will load Cadence. The Command Interpreter Window (CIW) will now load as
shown in Figure 1-1.

Figure 1-1: The Cadence CIW
Starting a Design
From the CIW select Tools
→ Library Manager to load the Library Manager
(Figure 1-2). The Library Manager stores all designs in a hierarchal manner. A library is
a collection of cells. For example, if you had a digital circuits library named Digital, it
will have several cells included in it. These cells will be inverters, nand gates, nor gates,
multiplexers, etc. Each cell has different views. These views will in general be things
such as symbols, schematics, or layouts of each cell.
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Figure 1-2: Library Manager
The first thing you need to do to start a design is create a library to store the cells
you will be designing in this lab. Let’s call this library “ee474”. From the Library
Manager select File → New → Library. Name the library “ee474” (without quotes) and
select OK. In the window that appears select “Attach to an existing techfile” (Figure 1-3)
and select OK. In the next window make sure that NCSU_TechLib_ami06 is selected
and select OK.

Figure 1-3: Creating a Library and Attaching a Tech Library
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Creating a Schematic
The first circuit we will design is a simple inverter. Select which library you want
to put the cell into, in this case “ee474”, and then File→ New → Cell. Name your cell
inverter. The tool you want to use here is Composer-Schematic as seen in Figure 1-5.

Figure 1-4: Creating a new cell view
After selecting OK, the schematic window opens. We wish to add two transistors
so that we can make an inverter. To do this we need to add an instance. You can do this
by either clicking Add → Instance or by pressing “i” on the keyboard. A window titled
“Component Browser” should pop up. Make sure that the library NCSU_Analog_Parts is
selected. Select N_Transistors and then nmos4. Go back to the schematic and select
where you would like to add the NMOS transistor. Go back to the Component Browser
and select P_transistors and then pmos4. Add this transistor to your schematic. Hit ESC
to exit the Add Instance mode.
Connect components together using wires. You can select Add
→ Wire or use
the “w” hotkey.
Pins identify the inputs and outputs of the schematic. Click Add → Pin or use the
“p” hotkey. Pin names and directions must be consistent between the symbol, schematic,
and layout. The name uniquely identifies the pin while the direction indicates the usage
of the pin. I recommend using the inputOutput direction for all pins.
To change the properties of a device use Edit→ Properties → Objects or use the
“q” hotkey. Try changing the width of the PMOS transistor from 1.5u to 3u. When
finished, your schematic should resemble Figure 1-6.
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Figure 1-5: Inverter
Select Design → Check and Save to save your schematic and make sure that there
are no errors or warnings.
Creating a Symbol
Return to the Library manager add a new cell view. This cell view will be a
symbol. Make sure that the type selected is schematicSymbol.

Figure 1-6: New Symbol
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The final symbol you create should resemble that shown in Figure 1-7

Figure 1-7: Final Inverter Symbol
Creating a Layout
After the schematic and symbol have been designed, it is time to move onto the
layout of the circuit. From the library manager select File→ New → Cell View. Layout
is done using the tool named Virtuoso. Select Layout as the Type (Figure 1-8). After
clicking OK, Virtuoso should open as well as the layer selection window (LSW, Figure
1-9).
The layout consists of rectangles, instances, and pins. A rectangle is used to
create gate, diffusion, and metal regions for the transistor. The gate region is created by
drawing a rectangle with poly (drw) or "r" on the keyboard. The diffusions for a
transistor are created by drawing a rectangle with the active (drw) layer. The intersection
of poly and active regions defines the size (length and width) of the transistors. In order
to define whether a
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Figure 1-8: Creating a layout cell view

Figure 1-94: The LSW
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transistor is NMOS or PMOS, nselect (drw) or pselect (drw) needs to surround the active
area. The design rules describe minimum spacing and size requirements for various
rectangles. Some basic design rules for this technology are shown in Figure 1-10.
2λ

5λ
λ

W

2λ

λ

4λ

2λ

Figure 1-5: Basic design rules
Substrate contacts and vias between layers of metal can be drawn by hand, be
added by selecting Create → Contact, or by using the “o” hotkey.
To add a pin, select Create → Pin. “Terminal Name” should be the name of the
pin in the schematic. Make sure that the “Display Pin Name” option is selected so that
the pin name will appear in the layout. “Pin Type” should be the same as the metal layer
that it is connecting to.
After completing the above steps, you should obtain a layout of the inverter which
resembles Figure 1-11.
After the layout is done, several steps have to be followed to insure that the layout
is correct. These steps involve performing the following analysis:
Table 1-2: Post layout steps
DRC

Design Rule Check. Checks physical layout data against fabrication-specific
rules. Typical checks include spacing, enclosure and overlap.

Extract Device parameter and connectivity are extracted from the layout in order to
perform ERC, Short Locator, LVS and post-layout simulation and analysis.
LVS

Layout Versus Schematic. Compares a physical layout design to the schematic
from where it was designed.
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Figure 1-61: Inverter layout
DRC
To run DRC for the layout, select Verify→ DRC. You do not need to make any
modifications to the window that opens up. Select OK to run the DRC. The total number
of errors will show up in the CIW as seen in Figure 1-12. Before going further we have
to reduce the number of errors to 0.
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Figure 1-12: CIW showing DRC errors
The errors will usually show up in the layout as white lines. To have Cadence
explain what the error is, select Verify → Marke rs → Explain. Click on one of the white
lines, and Cadence will explain what design rule you broke. Adjust the layout to fix these
errors and then rerun DRC until you have no design rule errors.
Extract
Once DRC is completed, you can now extract the layout. Select Verify
→
Extract. From this window, select “Set Switches”. Highlight “Extract_Parasitic_Caps”
and then click OK. Click OK again to extract the layout to make the extracted netlist.
LVS
The LVS window is shown in Figure 1-13. Make sure Rewiring, Device Fixing,
and Terminals are selected under LVS Options. Click Run. A window should pop up
once LVS has completed saying that the job succeeded. Click OK. From the LVS
window select output. The output should have a line that says “The net-lists match.” If
they do not match, go back to the LVS window. Select Error Display to find out what
your errors are. Adjust the layout to match, rerun DRC, Extract, and LVS until the
netlists match.
Once the schematic and layout match, go back to the LVS window and click
Build Analog and then OK.

Figure 1-7: LVS window

14

Simulating the Schematic
To test the inverter, we need to create a new schematic cell view called
“inverter_test”. To simulate the design, add the inverter symbol, signal sources, power
supplies, and loads as illustrated in Figure 1-14.

Figure 1-8: Inverter test schematic
Start the simulator environment by selecting Tools→ Analog Environment. The
simulator should appear in a few moments. Select Setup
→ Simulator/Directory/Host
and verify that spectreS is the simulator.
Next we need to configure the environment to run our first simulation. In the
Analog Environment window select Analyses
→ Choose. Select “dc” and then
“Component Parameter”. Select “Select Component” and then click on the desired
voltage source in the schematic to sweep. In this case we want to sweep the input voltage
source which is V0 in Figure 1-14. Select “dc” as the variable to sweep when the popup
window opens. We wish to sweep the source from the negative supply to the positive
supply, so input -1.5 into “Start” and 1.5 into “Stop”. Select OK.
The simulator should now be configured to run the simulation. Select Simulation
→ Run or click on the green light in the bottom right corner. Once the simulation has
completed, we can plot any outputs that we wish. To do this we use the calculator. To
access the calculator, select Tools → Calculator in the Analog Environment.
Since our analysis that was ran was a dc sweep, click the “vs” button (The “v” is
for voltage and the “s” is for DC sweep.) Next click on the output node in the schematic.
You can now plot the output as a function of the swept variable, which in this case is the
inverter input, by clicking “plot”. Your output waveform should resemble Figure 1-15.
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Figure 1-9: Inverter output plot
Simulating the Extracted Layout
To simulate the layout to verify that it operates as desired, you must do one thing
in the Analog Environment before running simulations. You will still open the Analog
Environment through the schematic window.
In the Analog Environment, select Setup → Environment. In the field labeled
“Switch View List” add “analog_exracted” before “schematic” as shown in Figure 1-16.
All other steps in simulation of the extracted view will now be the same as they were for
simulating the schematic.
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Figure 1-10: Adding extracted view to switch view list
Prelab
No prelab lab report is required this week other than the printouts listed in the
Prelab section.
Lab Report
This exercise is to be done during the lab under supervision of the TA. Turn in
print outs of the following as a lab report next week:
1) Inverter schematic
2) Inverter symbol
3) DC sweep output graph showing the inverter was simulated
4) Inverter layout
5) Copy of the LVS output file showing that the netlists match
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Lab 2: Layout Design
Objective
Learn techniques for successful integrated circuit layout design.
Introduction
In this lab you will learn in detail how to generate a simple transistor layout.
Next, techniques will be developed for generating optimal layouts of wide transistors and
matched transistors. Layout techniques for resistors and capacitors will also be
illustrated. Finally, you will use all of these layout techniques to produce a two-stage
opamp layout (Lab 3).
Layout Techniques
Transistors
In Lab 1 you learned how to layout small size transistors. Most analog designs
will not be limited to these small width transistors, thus special layout techniques need to
be learned to layout large width MOSFETS. Luckily, wide transistors can be broken into
parallel combinations of small width transistors as seen in Figure 2-1. By doing this
horizontal expansion technique for the wide transistor, the drain and source area can be
reduced which decreases parasitic capacitance and resistance.
D

G

D

G

D

S

S

S
D
D
D

G

S

D

S

D
S

S
G

Figure 2-1: Wide MOS transistor layout
Another good layout technique is to use “dummy” transistors on both ends of a
transistor layout. These dummy transistors insure that the etching and diffusion
processes occur equally over all segments of the transistor layout.

18

G

dummy
transistor

dummy
transistor

D

S

Figure 2-2: Dummy transistor layout
Notice the gate, drain, and source are connected together which keeps it from
conducting any current. This shorted transistor is connected to the drain or source of the
functional transistor. Another alternative for dummy transistors is to have the gate and
source tied together.
When laying out any device the key is symmetry, especially when laying out
fully-differential components. For matched devices, use interdigitized or commoncentroid layout techniques. A matched device is one where two transistors need to have
exactly the same geometries. Examples include current mirrors and differential pairs.
An interdigitized layout is shown in Figure 2-3. Notice that the two transistors
have been split into smaller size devices and interleaved. This layout minimizes the
effects of process variations on the parameters of the transistors.
The idea behind splitting a transistor up is to average the process parameter
gradient over the area of the matched devices. For example, the process variation of KP
and of the transconductance parameter on the wafer is characterized by a global variation
and a local variation. Global variations appear as gradients on the wafer as in Figure 2-4.
However, local variations describe the random change in the parameter from one point on
the chip to another nearby point. By using layout techniques such as interdigitized and
common-centroid, the process variation can hopefully be averaged out among the
matched devices.
When laying out wider matched transistors the common-centroid layout may be a
better choice. This layout technique is illustrated in Figure 2-5 for the case of 8 matched
M1 and M2 transistors of a differential pair.
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Figure 2-3: Interdigitized layout of a differential pair
a) Differential pair
b) Horizontal expansion
c) Interdigitized layout (Drain areas are different. Common centroid.)
d) Interdigitized layout (Drain areas are equal. Not common centroid.)
KP = 27 µA V 2

KP = 20µA V 2
KP = 29 µA V 2

KP = 25µA V 2

KP = 33µA V 2
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Figure 2-4: Gradient of KP on a wafer
G2

D1

D1

D2

S

D1

S

S

D2

S

D1
S
D2

G1

D2

D1

S

D2

S

D1

S

D2

S

S

Figure 2-5: Common-centroid layout of a differential pair
The idea behind the common-centroid layout is to average linear processing
gradients that affect the transistors’ electrical properties. Common-centroid layouts
should have the centroid (center of mass) of each transistor positioned at the same
location. The following examples illustrate what is common-centroid and what is not
common-centroid.
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Figure 2-6: Common-centroid examples
Capacitors
Capacitors of various types can be fabricated on integrated circuits. A capacitor is
formed when an insulator separates two conducting sheets. Two methods of forming
capacitors are by using poly and poly2 (elec layer in LSW) as the capacitor plates.

pins

rectangle
metal2

rectangle
metal1

instance
via

instance
m1_elec

instance
nwc

instance
m1_poly

rectangle
n-select

rectangle
poly

rectangle
n-well

rectangle
elec

Figure 2-7: Poly-Poly2 capacitor layout
Figure 2-7 illustrates the layout of the poly-poly2 capacitor. The capacitor is
formed by laying a second layer of polysilicon over the gate polysilicon. The area of the
top plate (poly2) and the perimeter determine the capacitance by the following equation:

C = CA ⋅ A + CF ⋅ P
where:
CA

is the capacitance per unit area for the chosen capacitor type

A

is the area of the top capacitor plate

CF

is the fringe capacitance per unit length for the chosen capacitor type for
diffusion based capacitors

P

is the perimeter of the top capacitor plate
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For poly-poly2 capacitors, a parasitic capacitance between the substrate and poly
can inject unwanted signals and noise into the circuit at the bottom plate of the capacitor.
To reduce this problem, put the capacitor in an N-well (for an N-well process) and
connect the well to a “clean” ground. A ground plane (metal sheet connected to ground)
can be used as a shield by covering all capacitors where possible.
For poly-diffusion capacitors, the bottom plate is placed in a special capacitor
well to reduce noise injection and to prevent voltage signals from altering the
capacitance. This produces a high quality linear capacitance.
To prevent the injection of noise from the substrate into the bottom plate of the
capacitor, always be sure to connect it to a low impedance node such as ground or the
output of an op-amp. Do not connect the bottom plate of a capacitor to an op-amp input.
The substrate noise is due partly to power supply noise and connecting the bottom plate
to the op-amp input allows direct injection of power supply noise into the op-amp input.
The power supply is used to bias the substrate, so they are usually directly connected.
When designing circuits, sometimes desired circuit performance depends on the
ratio of two capacitors. In such cases, it is important that two are more capacitors are
properly matched. Divide each capacitor into many smaller “unit” capacitors. For
matched devices this keeps the ratio of the areas and the ratios of the perimeters the same.
Like matched MOSFETS, the common-centroid layout technique can be
employed for matched capacitors. Figure 2-8 gives a simplified layout floor plan for two
equally sized, well-matched capacitors.
C2

C1

C2

C1

C1

C2

C1

C2

C2

C1

C2

C1

C1

C2

C1

C2

Figure 2-8: Common-centroid capacitor layout
The absolute and matching accuracy for various types of capacitors is given in the
following table:
Capacitor

Absolute Accuracy

Matching Accuracy

Poly1-Poly2
Poly-Diffusion

±20%
±10%

±0.06%
±0.06%
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Remember, the purpose of using the unit capacitor is to keep the ratio of the areas
and perimeters the same. This prevents (delta) variations in capacitor dimensions from
changing the capacitor ratio. If a non-integral number of unit capacitors are required then
the perimeters and areas can still be kept the same. If the ratio of capacitors is
C1
= I + N , where 1<N<2, then the unit capacitor has side length L0 and the non-unit
C2
capacitor has side lengths L1 and L2. Use the following formulas to calculate the side
lengths of the non-unit capacitor:

(

L1 = L0 N + N ( N − 1)

)

2
0

L
L1
Keep the unit capacitor side length L0 in the range from 10µm-25µm. Also,
within the capacitor array, use a consistent method of routing lines between the capacitor
segments. Each unit capacitor should be surrounded by similar routing lines. For
capacitors near the edge of the array, use “dummy” routing lines. Also, be sure that
parasitic capacitance formed by overlapping conductors is the same for the matched
capacitors.
L2 = N

Large unmatched capacitors can be divided into smaller unit capacitors to reduce
distributed effects caused by the relatively high resistivity polysilicon. This prevents a
large capacitor which possesses considerable resistivity as well as capacitance from
acting as a lossy transmission line.
Resistors
As for capacitors, many different types of resistors are available in integrated
circuits. Other than active devices biased to act as resistors, we can use the inherent
resistivity of the polysilicon or diffusions to create resistors. The following table shows
the typical values of resistance for the AMI 0.6μm process that we will be using to design
circuits.
PROCESS PARAMETERS N+
P+
POLY PLY2_HR
Sheet Resistance
83.9 109.5 22.3 1014
Contact Resistance 64.7 169.6 15.6

POLY2 M1 M2
UNITS
40.3 .09 .09 ohms/sq
25.9
0.90 ohms

The total resistance of a monolithic resistor is the sum of the contact resistance
and the ohmic resistance of the diffusion material. The following formula can be used to
estimate resistance for polysilicon and diffusion resistors:
R = RS ⋅

L
+ 2⋅RC
W

where:
RS

is the resistance per square for the chosen resistor type

L

is the length of the resistor
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W

is the width of the transistor

RC

is the contact resistance

Figure 2-9 shows a polysilicon resistor layout. The resistor is constructing by
adding a strip of poly and then by adding poly contacts. Next the “res_id” layer is added
which tells the extraction program that this is a resistor that needs to be included in the
extracted netlist.
res

poly

Figure 2-9: Poly resistor layout
If the circuit operation depends on the ratio of resistance, then good matching can
be obtained by using interdigitized or common-centroid techniques. When matching
resistors, be sure to keep device orientation and sizes the same. Also, since contacts
contribute resistance, keep the contacts in the same ratio. An interdigitized layout of
resistors is illustrated in Figure 2-10. Notice that the interconnecting metal is overlapping
the resistor array and non-overlapping the resistor array in equal lengths for the two
resistors.
R2
R1

R1

R2

R1

R2

R1

R2
R2
R1

Figure 2-10: Interdigitized resistor layout
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Prelab
Answer the following questions. No computer work is required for the prelab. The
prelab is due at the beginning of class.
1) What are the absolute minimum dimensions of a transistor? Explain your
reasoning. Remember to consider minimum contact size. Do we actually use this
minimum size of do we use a slightly larger size for convenience.
2) Draw a common-centroid layout of a current mirror with equal size transistors of
L = 0.6 μm and W = 19.2 μm. Use a finger length of 2.4 μm devices for each
transistor segment. Remember to draw drain, source, gate, and bulk connections.
Use dummy transistors and all other good layout techniques learned in the lab.
Include a floor plan.
3) Design a common-centroid layout for a poly1-poly2 capacitor array. The
capacitors have a ratio of 1.32:1. The capacitor array should consist of eight unit
capacitors and one non-unit capacitor. Determine the form of the commoncentroid layout and interconnect the capacitors. Each unit capacitance should
have a separate top and bottom plate. Do not use a common bottom plate. Use
the techniques described in the lab manual to give good matching. Also, give the
size of the non-unit capacitor. The unit capacitor is 25 μm by 25 μm.
4) Design a matched polysilicon resistor pair to realize a resistance of 1200 Ω each.
Remember to include contact resistance. Determine the approximate length and
width of the diffusion. Use an interdigitized layout with six resistance segments.
Use good layout techniques.
Lab
1. Practice good layout techniques by laying out the following:
A) Current-mirror from prelab question #2
B) Capacitor array from prelab question #3
C) Matched resistors from prelab question #4
2. Include in the lab report
A) Schematic printout
B) Layout printout
C) LVS printout showing that layout and schematic match
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Lab 3: More Layout Techniques
Guard Rings
When laying out sensitive analog blocks, we need to help minimize the effect of
substrate noise. One way to do this is with a guard ring. A guard ring is an array of
substrate contacts which will then be connected to a clean supply (VSS or ground).
Figure 3-1 illustrates an example of a guard ring. This example shows a ring with
a single contact. For more isolation, this ring can be made wider with more substrate
contacts.
It is also important to note that the PMOS devices have an n-well contact ring
surrounding them. This is good practice because it helps to act as an additional guard
ring while also minimizing the possibility of latch up between the n-well and substrate.

nwell
PMOS Devices

m1_substrate
NMOS Devices

Figure 3-1: Guard ring illustration
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m1_nwell

Prelab
There is no prelab work required for this lab.
Lab
Use good layout techniques with guard rings to create a layout of the two-stage op-amp
in Figure 3-2. Table 3-1 lists the transistor sizes for the op-amp. Figure 3-3 is a
suggested floor plan to use. In this floor plan each transistor has a finger width of 2.4μm.
Include in the lab report:
A) Schematic printout
B) Layout printout
C) LVS printout showing that layout and schematic match

Figure 3-2: Two-Stage Op-Amp
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Table 3-1: Transistor Sizes
MOSFET
M1
M2
M3
M4
M5
M6
M7
M8

W
9.6u
9.6u
19.2u
19.2u
4.8u
9.6u
19.2u
76.8u

L
600n
600n
600n
600n
600n
600n
600n
600n

D

D

D

D

D

D

D

D

M8

M8

M8

M8

M8

M8

M8

M8

D

D

M3

M3

M4

M4

M3

M3

D

M8

M8

M8

M8

M8

M8

M8

M8

D

D

M4

M4

D

D

M4

M4

D

M8

M8

M8

M8

M8

M8

M8

M8

D

D

M3

M3

M4

M4

M3

M3

D

M8

M8

M8

M8

M8

M8

M8

M8

D

D

M1

M1

M2

M2

M2

M2

M1

M1

D

D

D

D

D

D

D

D

D

M5

M6

M6

M7

M7

M7

M7

M7

M7

M7

M7

M6

M6

M5

D

D

CC

Figure 3-3: Floor plan for two-stage op-amp layout
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Lab 4: MOS Device Characterization
Objective
Understand and measure transistor model parameters.
Introduction
In this lab you will review basic transistor operation and learn how the SPICE
model parameters relate to the physical structure and electrical equations of the device.
Then you will measure various electrical model parameters: VT0, λ, KP, and γ.
Transistor Operation
MOS transistors are the fundamental devices of CMOS integrated circuits. The
schematic symbols for an NMOS and PMOS transistor are illustrated in Figure 4-1 and
Figure 4-2.
D
B

G
S

Error! Objects cannot be created from editing field
codes.

Figure 4-1: NMOS Transistor

Figure 4-2: PMOS Transistor

A cross sectional view of an NMOS transistor is shown in Figure 4-3. When the
potential difference between the source (S) and drain (D) is small (~ 0V), and a large
potential (> VT0) is applied between the gate (G) and source, the transistor will be
operating in the linear or ohmic region. The positive gate potential causes electrons to
gather below the surface of the substrate near the gate in a process called “inversion”.
This region of mobile charge forms a “channel” between the source and drain. The
amount of charge is a function of the gate capacitance (Cox) and the gate-to-source
overdrive voltage:
Q m = C ox (VGS − VT0 )
S

G

D

+++++++++++++
-----------------N+

Qm

N+

P-

Figure 4-3: Cross-sectional view of an NMOS transistor
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The term VT0 is the threshold voltage. When the gate-to-source voltage (VGS),
exceeds this value, an inversion region is formed. Before reaching the inversion region,
as the gate-to-source voltage is increased, the transistor passes through the accumulation
region where holes are repelled from and electrons are attracted to the substrate region
under the gate. Immediately before inversion, the transistor reaches the depletion region
(weak-inversion) when the gate-to-source voltage is approximately equal to the threshold
voltage. In this region a very small current flows.
In the linear region, the MOSFET acts as a voltage-controlled resistor. Resistance
is determined by VGS, transistor size, and process parameters.
When the drain-to-source voltage (VDS) is increased, the quantity and distribution
of mobile charge carriers becomes a function of VDS as well. Now the total charge is
given by:
Q m = C ox (VGS − VT − VDS )
The threshold voltage (now denoted as VT) becomes a function of VDS. The
distribution of this charge is such that Qm is greater near the source and less near the
drain. To find the channel conductance, the charge must be recast as a function of
position Qm(y) and integrated from the source to drain. Since the charge was a function
of VDS, the conductance depends on VDS. The channel current becomes:
I D = μ 0 ⋅ C ox ⋅

W
(VGS − VT ) ⋅ VDS
L

or
I D = KP ⋅

W
(VGS − VT )⋅ VDS
L

As VDS increases, eventually the drain current saturates. That is, an increase in
VDS does not cause an increase in current. The saturation voltage depends on VGS and is
given by VDS(sat) = VGS – VT. The equation for the drain current becomes:
ID =

1
W
2
⋅ KP ⋅ (VGS − VT0 )
2
L

At this point the transistor is operating in the saturation region. This region is
commonly used for amplification applications. In saturation, ID actually depends weakly
on VDS through the parameter λ. Also, the threshold voltage depends on the bulk-tosource voltage (VBS) through the parameter γ. A better equation for the MOSFET in
saturation is given by:
ID =

1
W
2
⋅ KP ⋅ (VGS − VT ) ⋅ (1 + λ ⋅ VDS )
2
L

In the equation above VT includes the effects of VBS.
When VGS is less than the threshold voltage, the channel also conducts current.
This region of operation is called weak-inversion or sub-threshold and is characterized by
an exponential relationship between VGS and ID. Also, when VGS becomes very large the
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charge carrier’s velocity no longer increases with the applied voltage. This region is
known as saturation and has an ID that depends linearly on VGS as opposed to the squared
relation shown above.
Figure 4-4 is a three-dimensional cross-sectional view of a MOSFET. Notice in
the figure the overlap between the gate region and the active regions. The overlap forms
parasitic capacitors CGS and CGD.
CGB=CGBO*L

GATE

CGD=CGDO*W
RD=RSH*NRD

CGS=CGSO*W
RS=RSH*NRS

DRAIN

SOURCE
POLY Si

WM

LM
OXIDE

TOX
N+

L

CJD=CJ*AD

P-

CSWD=CJ*PD

NSUB

N+

LD

XJ

CJS=CJ*AS
CSWS=CJ*PS

Figure 4-4: Physical structure of a MOSFET
The reverse-biased junctions between the active regions and the bulk form the
parasitic capacitors CDB and CSB. The conductivity of the active regions forms the
parasitic resistors RD and RS. A schematic symbol with the parasitic resistors and
capacitors is illustrated in Figure 4-5.
DRAIN
RD
CGD

CDB=CJD+CSWD

GATE

BULK
RB

RG

CSB=CJS+CSWS

CGS

RS
SOURCE

Figure 4-5: MOSFET parasitic resistors and capacitors
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Device Characterization
To characterize the MOSFETs so that hand calculations can be done in the future,
simulations need to be done to measure KP, VT0, λ, and γ.
λ Measurement
To measure λ you need to do a DC sweep of VDS and plot ID as shown in Figure
4-6. Each curve represents a different VGS value. Any one of these curves can be used to
calculate λ. Make sure that VBS is 0V for this simulation. The formula for calculating λ
given two points on the saturation portion of a single curve is:
λ=

I D2 − I D1
I D1 ⋅ VDS2 − I D2 ⋅ VDS1

Figure 4-6: NMOS I-V charateristic plot
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VT0 Measurement
VT0 can also be obtained from Figure 4-6. Using the saturation portion of two
curves with equal VDS, VT0 can be calculated as
VGS1 −
VT0 =
1−

I D1
⋅ VGS2
I D2
I D1
I D2

KP Measurement
Knowing λ and VT0, KP can easily be found from the equation for MOSFET drain
current in the saturation region. A little algebra gives that KP is
KP =

2 × ID
W
2
× (VGS − VT0 ) × (1 + λ × VDS )
L

γ Measurement
To obtain γ you must first give the transistor a non-zero VBS. Next calculate the
new VT using the same procedure that you used to obtain VT0. γ is then given as
γ=

VT − VT0
Φ 0 − VBS − Φ 0

Φ0 is the built-in potential of an open-circuit pn junction and can usually be
approximated to be 0.9V.
Simulation
In order to obtain the ID vs. VDS vs. VGS plot of Figure 4-6, you need to setup your
schematic as shown in Figure 4-7. A simple DC sweep of VDS needs to be performed,
however to get multiple I-V curves, a parametric analysis needs to be run.
To do a parametric sweep on your VGS voltage source, you need to setup a design
variable in Cadence. First, modify the properties of the VGS source. Instead of giving a
constant DC voltage, make it a variable by naming it “vgs”. In the Analog Environment
window, select Variables → Edit. In the “Name” field type “vgs”. You can give a value
to the variable that Cadence will use for all simulations other than the parametric sweep.
Once finished, select “Add” and then “OK”.
To get to the parametric analysis simulation, go to the Analog Environment and
select Tools → Parametric Analysis. In the “Variable Name” field add “vgs”. Sweep
from 1.0 to 1.4 with 5 steps. Choose Analysis
→ Start to run the parametric sweep.
Once the simulation is finished, use the calculator to plot ID.
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ID

VGS

VBS

VDS

Figure 4-7: Simulation Test Setup
Prelab
No computer work is required for the prelab.
1) Derive the equations for the four electrical parameters given in the Device
Characterization portion of the manual.
Lab
1) Use Cadence to produce ID vs. VDS vs. VGS plots similar to Figure 4-6 for transistors
of size 4.2/0.6 and 8.4/1.2.
2) Extract the four electrical parameters for both NMOS and PMOS transistors for both
transistor sizes.
3) Compare the extracted parameters to the equivalent parameters given in the model
file. Compute the percent difference and explain any discrepancies.
Note: To find the model file used, go to the Analog Environment window. Select Setup
→ Model Path. Once you know the model path, go to this directory and use a text editor
to view the models ami06N.m and ami06P.m.
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Lab 5: Current Mirrors
Objective
Design, simulate, layout, and test various current-mirror circuits.
Introduction
Current mirrors are fundamental building blocks of analog integrated circuits.
Operational amplifiers, operational transconductance amplifiers, and biasing networks are
examples of circuits that are composed of current mirrors. Analog integrated circuit
implementation techniques such as current-mode and switched current use current
mirrors as the basic circuit element. The design and layout of current mirrors is therefore
an important aspect of successful analog circuit design.
In the simplest form, a current mirror is composed of two transistors as shown in
Figure 5-1. Transistor M1 is diode connected and acts as the low-impedance input of the
current mirror. The drain of M2 is the output of the current mirror.

VDD
Iin

Iout

M1

M2

Figure 5-1: Simple current mirror
Since the gate-to-source voltage is the same for both transistors, then, according
to the first-order MOSFET model, the drain currents will be equal. This assumes that the
transistor sizes are equal as well as the process parameters.
A current mirror is used to mirror the input current into the output branch. A
current (Iin) entering the diode connected transistor establishes a gate voltage (VGS). The
gate voltage causes Iout to flow through the output transistor. Notice that the input
transistor will show a low small-signal resistance (1/gm) and the output transistor will
exhibit a high small-signal resistance (ro).
If the ratio of the transistors is changed, then the current-mirror acts as a current
amplifier. The gain of the amplifier is given by:
 W2 

L 2 
Ai = 
 W1 
 L 
1
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The above analysis assumed ideal operation of the current mirrors meaning that
the drain currents are independent of VDS; however, due to channel length modulation we
know this not to be true. The following equation, which you should be familiar with by
now, illustrates the dependence of drain current on VDS.
ID =

1
W
2
⋅ KP ⋅ ⋅ (VGS − VT ) ⋅ (1 + λ ⋅ VDS )
2
L

The excess current due to differences in VDS1 and VDS2 will cause a difference in
ID1 and ID2. To reduce “lambda” effects, the drain-to-source voltages of the two
transistors need to be kept equal.
Another non-ideality of current mirrors is the limited range of VDS2. Since M1
remains in saturation for all input currents due to its diode connected configuration, M2
needs to be kept in saturation to assume proper operation. If VDS2 drops too low, M2 will
enter the triode region, and the output current will be much less than what is wanted. The
minimum output voltage required for the current mirror is sometimes referred to as the
compliance voltage. For the simple current mirror, the compliance voltage is VDS,sat2.
The ratio of the input to output currents is also process dependent. Because of
this process dependency, good layout techniques such as interdigitized and commoncentroid methods are used to layout current mirrors.
As previously mentioned, to obtain good matching between input and output
currents, the drain-to-source voltages of M1 and M2 must be kept equal. One way to
achieve this is by using a cascode current mirror which is pictured in Figure 5-2.

VDD
Iout

Iin

M3

M4

M1

M2

Figure 5-2: Cascode current mirror
Transistors M1 and M2 determine the ratio of the input and output currents. M3
biases M4 which is used to control the drain voltage of M2. If designed correctly, VDS1 is
approximately equal to VDS2. The benefits of the cascode current mirror are better
matching of output currents and larger output resistance. The disadvantage is that a
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larger compliance voltage is needed to keep both M2 and M4 in saturation. To find the
compliance voltage we will use Figure 5-3.

VDD
Iout

Iin

3

M3

M4

1

2

M1

M2

Figure 5-3: Cascode current mirror
Node 1: The voltage here is VGS1 = VT + VDS,sat1.
Node 2: For good matching between input and output currents, we want VDS1 and
VDS2 to be equal. Thus, the voltage at node 2 is also VT + VDS,sat1.
Node 3: The minimum compliance voltage will be the minimum voltage to keep
M3 and M4 in saturation. This will be VT + VDS,sat1 + VDS,sat2.
As you can see, adding the cascode transistor does not just increase the required
compliance voltage by one VDS,sat, it also increases it by a threshold voltage. If we have
200 mV overdrive voltages on all transistors with threshold voltages of 700 mV, the
output voltage will have to be greater than 1.1 V. This makes cascode current mirrors not
desirable for modern processes since the required supply voltage is already small.
In order to have the good current matching capabilities of the cascode current
mirror, while not having such a large compliance voltage, we can use the low voltage
cascode current mirror as pictured in Figure 5-4. If designed correctly, M1 and M2 will
be biased such that they are at the edge of saturation, thus their VDS ≈ VDS,sat. If this is the
case then the compliance voltage drops to VDS,sat2 + VDS,sat4. This is one whole threshold
voltage less than the regular cascode current mirror of Figure 5-2. MB will usually have a
small W/L ratio, and should have a VDS,sat = VDS,sat1 + VDS,sat2.
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VDD

VDD
Ibias

Iin
M3

MB

Iout

M4

M1

M2

Figure 5-4: Low voltage cascode current mirror
Simulating Current Mirrors

VDD
Iin

Vout

M1

M2

Figure 5-5: Current mirror test configuration
Once a current mirror has been designed (hand calculations), use the test
configuration in Figure 5-5. Iin is whatever DC current you designed your current mirror
to have. Vout is a DC source that will be varied in a DC sweep simulation. Plot ID2 vs.
Vout, and you should get a plot which resembles Figure 5-6. The compliance voltage will
be the point on the plots where Iout begins to change rapidly indicating the output
transistor is entering the linear region of operation.
In order to find the output impedance an AC simulation needs to be run. First,
give Vout a DC voltage greater than VDS,sat (say 1V) with an AC voltage of 1V. The
output impedance will be the plot of the inverse of the AC drain current. An example is
shown in Figure 5-7. In this example the output impedance is about 60 kΩ at low
frequencies and then begins to decrease around 10 GHz.
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Figure 5-6: Current mirror simulation results

Figure 5-7: Current mirror output impedance
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Prelab
The prelab exercise is due at the beginning of the lab period.
1) Make a table which lists the three current mirror topologies described in this lab.
Rate each topology using good, medium, or bad for the following design
considerations: Rout, accuracy, complexity, and compliance voltage.
2) Design a simple 1:1 current mirror that has a compliance voltage of 150 mV to 200
mV. The output current should be 100 μA. Determine W/L for each transistor and
what the expected output impedance should be.
3) Design a low-voltage cascode current mirror with a 1:2 input current to output current
ratio. The low frequency output impedance should be greater than 2 MΩ. Assume a
50 μA input current.
Lab
1) Simple current mirror
A) Design in Cadence the simple current mirror from the prelab. If needed, modify
the design so that it meets the given specifications.
B) Generate the plots of Figure 5-6 and Figure 5-7 for this design. Determine the
compliance voltage, low frequency output impedance, and comment on the
accuracy.
C) Layout the current mirror. Run post layout simulations. Include plots of both
layout and schematic simulations in your lab report.
2) Low-voltage cascode current mirror
A) Design in Cadence the low-voltage cascode current mirror from the prelab. If
needed, modify the design so that it meets the given specifications.
B) Generate the plots of Figure 5-6 and Figure 5-7 for this design. Determine the
compliance voltage, low frequency output impedance, and comment on the
accuracy.
C) Layout the current mirror. Run post layout simulations. Include plots of both
layout and schematic simulations in your lab report.
3) Be sure to include in your reports the LVS results showing that the layout matches the
schematic.
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Lab 6: Inverting Amplifiers
Objective
Design, simulate, and layout various inverting amplifiers.
Introduction
Inverting amplifiers are fundamental building blocks of electronic circuits. These
amplifiers are used in a variety of circuit applications such as the gain stage of
operational amplifiers and as the NOT gate in digital logic. Due to the utility of inverting
amplifiers, learning the process of analyzing and designing these basic building blocks is
important to successful circuit design.
Studying inverting amplifiers also gives us insight into basic circuit concepts such
as small-signal frequency response and feedback. In this lab, the small-signal model of a
generic inverting amplifier is analyzed while a generic design procedure is developed.
Next, the lab manual presents advantages and disadvantages of several circuit structures.
Finally, the students will design various inverting amplifiers by choosing a circuit
structure and developing a design procedure.
The basic inverting amplifier is shown in Figure 6-1. The input signal Vin will
contain an AC signal component as well as a DC component used to set the operating
point:
vIN = VBIAS + vin
Transistor M1 is called the driver since the input signal controls the amplifier from
this point. An ideal load will have infinite impedance. In the basic inverting amplifier
circuit of Figure 6-1, the load is represented by an ideal current source.
The DC operating point of the circuit is determined by IBIAS and VBIAS. These
currents and voltages determine the transistor’s small-signal parameters and establish the
quiescent output voltage.
vdd

Vin

Ibias

Vout

Vin

M1
vss

Figure 6-1: Basic inverting amplifier
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Vout

The small-signal model for an inverting amplifier is given in Figure 6-2. The
circuit consists of two connected nodes which will result in two poles and one zero. The
resistance RA represents the voltage source’s resistance RS and any resistance used to
establish the DC biasing. The resistance RB includes the load resistance and the smallsignal output resistance of the driving transistor. The capacitance CA includes source
capacitance and the small-signal input capacitance of the transistor. Similarly, CB
represents the load capacitance and the small-signal output capacitance of the transistor.
Finally, CC consists of any external stray capacitance and internal capacitance between
the drain and gate of the driving transistor.
Vin

RA
+
VA
-

CC
CA

Vout
Gm V A

RB

CB

Figure 6-2: Generic inverting amplifier small-signal model
Using node voltage equations or mesh currents, the input-output transfer function
for the inverting amplifier can be obtained by with some work. The transfer function for
the generic amplifier of Figure 6-2 is given by:
CC  G m 

s −
R A 
CC 
H(s ) =


(C A + CC )(C B + CC ) − CC2 s 2 +  C A + CC + C B + CC + G m CC s + 1
RA
 RB
 R AR B

(

)

(1)

This formula is too complicated to gain any useful insight as to how various
resistors and capacitors affect the frequency response of the inverting amplifier. Various
assumptions can be made to simplify (1). If we make the assumptions CB >> CA and
CC >> CA, then the transfer function can be simplified to:
H(s ) =

1
R ACB

 Gm 

 s −
C
C 






1
1
Gm 
1
2

s +
+
+
s+
 R BC B
C BC C
C B  R A R BC BC C
RA


C B + CC



(2)

This simplification is useful because CC is generally a large transistor used to set
the gain-bandwidth product, and the total load capacitance is generally larger than any
parasitic input capacitances.
Next, we can simplify (2) in two different meaningful ways. The first way
assumes RA is small while the second assumes RA is large. Using the first assumption
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that RA is small, we have RA << RB and RA <<
the transfer function in (2) becomes:

1
. With this simplifying assumption,
Gm

 Gm 
 s −

C
C


H(s ) =




1
1
2
s +

s +

CBCC  R A R BCBCC

 RA
CB + CC 

1
R ACB

(3)

Also, if we assume the poles are far apart, that is p1 << p2, then we can use the
following simplification when factoring:
D(s ) = (s + p1 )(s + p 2 ) = s 2 + (p1 + p 2 )s + p1p 2 ≈ s 2 + (p 2 )s + p1p 2
The above simplification assumes a dominant pole exists. The dominant pole is
the pole which is significantly closer to the origin than all the other poles. The nondominant poles occur at a much greater frequency than the dominant poles. Using this
simplification, the denominator in (3) can be factored as shown in (4). From (4) the poles
can easily be determined.
 Gm 

 s −
C
C 

H(s ) =




1
1
 s +
 s +

C
BC C
 (CB + CC )R B  R A
C B + CC

1
R ACB








(4)

Now that the transfer function is in factored form, we can find the DC gain, poles,
and zero for the case when CA is small and RA is small:
A V 0 = −G m R B
p1 =
p2 =

z=

−1
(CB + CC )R B
−1
C BC C
RA
C B + CC

(CA is small, R A is small)

Gm
CC
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1
. With this assumption, the
Gm
transfer function given by (2) can be factored using the procedure given above:

Assuming RA is large, that is RA ≈ RB and RA >>

1  Gm 

s −
R A CB 
CC 
H(s ) =

 G m 
1

 s +
 s +
C
G
R
R
C
B 
m A B C 


(5)

With this transfer function in factored form, we can find the DC gain, poles, and
zero for the case when CA is small and RA is large:
A V 0 = −G m R B
p1 =

−1
−1
=
G m R BC C R A A V 0 C C R A

p2 =

− Gm
CB

z=

(CA is small, R A is l arg e )

Gm
CC

Notice that the dominant pole has been shifted towards the origin. This is an
example of Miller’s Effect.
Next the frequency response of the two transfer functions derived above will be
examined. For the case when RA is small, the poles are greatly separated. Usually this
system can be represented adequately by a first-order transfer function. The pole-zero
diagram is shown in Figure 6-3. Since this system is first-order stability problems are
less likely; however, the right-half plane zero will reduce phase margin. If stability
becomes a problem, increase CB relative to CC.

p2

p1

z1

Figure 6-3: Pole-Zero diagram for small RA
For the case when RA is large, the system consists of a dominant pole, a nondominant pole, and a right-half plane zero. Due to these three phase margin reducing
components, careful circuit design is required to guarantee stability. The zero reduces
phase margin and should be placed as far to the right as possible, while the non-dominant
pole should be placed as far to the left as possible. Figure 6-4 illustrates the pole-zero
diagram for this system.

45

p2

p1

z1

Figure 6-4: Pole-Zero diagram for large RA
Two other simplifications are shown below. The first simplification assumes
CA>>CB, CA>>CC, and RA≥RB. This situation may occur when the inverter is used to
amplify a signal from a capacitive transducer.
A V 0 = −G m R B
p1 =

−1
R A ⋅ CA

p2 =

−1
R B (C B + CC )

(CA is l arg e, R A is l arg e )

Gm
CC
The second set of equations assumes CB>>CC, CB>>CA, and RB≥RA.
equations are useful if a wideband inverter is driving a capacitive load.
z=

A V 0 = −G m R B
p1 =

−1
R B ⋅ CB

p2 =

−1
R A (CA + CC )

z=

(CB is l arg e, R B is l arg e )

Gm
CC
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These

Design Description
This section of the lab will discuss in detail four inverting amplifier configurations. The first inverter uses a current-mirror as the active load. The second is a basic
inverter commonly used in CMOS digital logic. The last two amplifiers employ diode
connected transistors as loads. The last to amplifiers employ diode connected transistors
as loads. Each of these amplifiers has characteristics which makes its use advantageous
in certain applications.
Inverter with Current-Mirror Load
The inverter of Figure 6-5 employs an NMOS driver and a PMOS current-mirror
as the load. The current-mirror provides a large small-signal output resistance and
constant biasing current. The biasing current establishes the operating point for transistor
M1, which in turn determines its small-signal transconductance. This circuit can provide
a high output resistance and a large small-signal gain.
A disadvantage of this circuit is the need for a biasing current which requires
additional circuitry. However, since this circuit is biased by another circuit, this amplifier
can be programmed or tuned to operate at a specific operating point even during the
presence of process variations.

VDD
M2

M3
Cm
IBIAS
Vin

Vout

RS
M1
VSS

Figure 6-5: Inverting amplifier with current-mirror load
Design Procedure
This design procedure is only an example. To achieve the desired inverter performance
another procedure may need to be used.
1) Determine the Miller compensation capacitor Cm from the gain-bandwidth product
(GBW) specification. Remember GBW = AV0 ∙ p1.
2) To guarantee stability be sure the phase margin is greater than 60º, make sure the
non-dominant pole p2 is at least three times greater than the GBW. Use this
information along with the load capacitance to determine gm1.
3) Determine IBIAS to provide the desired DC gain.
4) Using gm1 and IBIAS, determine the size for transistor M1.
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5) Use a 1:1 current-mirror sized such that the transconductance is equal to that of the
driver transistor.
Digital CMOS Inverter
Figure 6-6 illustrates the basic CMOS inverter. This circuit is commonly used in
digital logic circuits. Since both transistors are driven by the input source, the voltage
gain will be higher with this circuit than the amplifier with the current-mirror load.
An advantage of this circuit is that it does not need external biasing circuitry. The
operating point of this circuit is determined by the ratio of the transistor sizes. Using
large transistors will cause Gm to be high. This allows higher frequency operation when
driving large capacitive loads.
VDD
M2
Cm

Vin

Vout

RS
M1
VSS

Figure 6-6: Digital CMOS inverting amplifier
Figure 6-7 illustrates the effect of changing the ratio of the transistors. Typically,
the transition region will be half the supply voltage. In this case, the products of the
transconductance and transistor sizes for the NMOS and PMOS must be equal. If process
variations cause KP or KN to change, then the transition region will shift.
Figure 6-7 also shows the gain and linearity of the amplifier. The slope of the
curve at any point it the gain. The vertical section of the graph is a region of high gain.
Since the slope of the curve changes with signal amplitude, the amplifier exhibits high
distortion. To obtain low distortion operation, the input voltage must remain small.
Design Procedure
This design procedure is only an example. To achieve the desired performance another
procedure may need to be used.
1) First, notice the DC gain is determined by the power supply voltage for symmetrical
operation:
1
2
2
=
=
λ I BIAS λ (VGS − VT ) λ (VDD − VT )
2) Determine Miller Compensation capacitor Cm from gain-bandwidth product (GBW)
specification or dominant pole specification. Remember GBW = AV0 p1.
A V 0 = G m R B = g m1
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Vout

W 
KPP  
 L P < 1
W 
KPN  
 L N

W 
KPP  
 L P = 1
W 
KPN  
 L N

VDD

W 
KPP  
 L P > 1
W 
KPN  
 L N

0

VSS

-∆V 0 ∆V

Vin

Figure 6-7: Transition regions for various transistor size ratios
3) To guarantee stability be sure the phase margin is greater than 60°. This requires the
non-dominant pole p2 to be at least three times higher in frequency than the gainbandwidth product (p2 > 3 GBW). Use this information to determine gm1.
4) Remember, for symmetrical operation the transistors must be in the ratio:
W
N
L =1
W
KP P
L
5) Using the value for gm1 and the above equation, determine the size for transistors Ml
and M2. Remember, the current through both transistors is the same.
KN

K N,P

g m1, 2
W
N, P =
(VDD − VT )
L

PMOS Only Inverter with Self-Biased Load
Figure 6-8 shows a PMOS inverter. This inverter does not require a CMOS
process. Due to the diode connected load, the inverter has a low output resistance which
in turn gives it a low gain. This inverter however is very linear.
The derivation of the large-signal transfer function is easy. Assume both
transistors are the same size and perfectly matched. Since the drain current is the same
for both transistors:
I = I D1 = I D 2 =

W
1
(VGS1 − VT )2
KP
2
L

and M2 is diode connected, Vout is given by:

49

Vout = VSS + VGS2
Vout = VSS +

2I
+ VT
W
KP
L

The gate to source voltage of M1 is equal to the input voltage and the equation becomes:

Vout
Vout

1
W
(VDD − Vin − VT )2
KP
2
L
= VSS +
W
KP
L
= VSS + VDD − Vin
2

Vout = −Vin
VDD
Vin

RS

M1
Cm
Vout
M2
VSS

Figure 6-8: PMOS only inverter with self-biased load
Design Procedure
This design procedure is only an example.
performance another procedure may need to be used.

To achieve the desired inverter

1) First, notice the DC gain is determined by the sizes of the transistors. For a unitygain buffer, the gain is one.
AV0 = G mR B =

g m1
gm2

2) Determine the Miller compensation capacitor Cm from the dominant pole location of
the GBW product specification.
3) To guarantee stability, be sure the phase margin is greater than 60º. This requires the
non-dominant pole p2 to be at least three times higher in frequency than the GBW
product. Use this information to determine gm1 and gm2.
4) Using the value for the transistor transconductance determine the size for transistors
M1 and M2. Remember, the current through both transistors is the same.
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CMOS Inverter with Self-Biased Load
The inverter of Figure 6-9 is similar to the previous inverter except it requires a
CMOS process. Matching of transistors is also difficult. Use a design procedure similar
to the previous inverter.
VDD
M2

Vin

RS

Vout

Cm
M1
VSS

Figure 6-9: CMOS inverter with self biased load
Summary of AC Characteristics
Table 6-1 lists the capacitors and resistors from Figure 6-2 and gives the
parameter value for each of the four configurations. This table does not include all
possible parasitic capacitance associated with the transistors. The table also does not
include stray capacitance associated with circuit layout. Depending on the application,
the stray capacitance might be a significant component of the frequency response.
Table 6-1: Relationship between the generic amplifier model and various inverter
circuits
Current-Mirror
Load

Digital CMOS

Self-Biased
PMOS

Self Biased
CMOS

RA

RS

RS

RS

RS

RB

ro1||ro2||RL

ro1||ro2||RL

ro1||1/gm2||RL

ro1||1/gm2||RL

CA

Cgs1

Cgs1+ Cgs2

Cgs1

Cgs1

CB

(Cbd1||Cbs1)+

(Cbd1||Cbs1)+

(Cbd1||Cbs1)+

(Cbd1||Cbs1)+

(Cbd2||Cbs2)+

(Cbd2||Cbs2)+

(Cbd2||Cbs2)+

(Cbd2||Cbs2)+

CL

CL

CL+ Cgs2

CL+ Cgs2

CC

Cgd1+Cm

Cgd1+Cgd2+Cm

Cgd1+Cm

Cgd1+Cm

Gm

gm1

gm1+gm2

gm1

gm1
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Prelab
The prelab exercises are due at the beginning of the lab period. No late work is accepted.
1) Create a table ranking the various amplifiers as good, medium, or poor in the
following categories: gain, input impedance, output impedance, and linearity.
Include the expressions for each design specification (except for linearity).
2) Derive the transfer function for the generic amplifier by applying Miller’s Theorem.
Compare this transfer function to the one derived in the lab manual. Comment on the
utility of Miller’s Theorem.
3) Design the following inverting amplifiers:
A) Current-mirror load inverter with the following specifications:
GBW = 1 MHz, PM = 60º, AV0 = 30 dB, VDD = VSS = 1.5 V, RS = 100 kΩ, CL = 30 pF
B) Digital CMOS inverter with the following specifications:
GBW = 1 MHz, PM = 60º, AV0 = 30 dB, VDD = VSS = 1.5 V, RS = 100 kΩ, CL = 30 pF
C) PMOS inverter with the following specifications
GBW = 1 MHz, PM = 60º, AV0 = 0 dB, VDD = VSS = 1.5 V, RS = 100 kΩ, CL = 30 pF
D) Self-biased CMOS inverter with the following specifications
GBW = 1 MHz, PM = 60º, AV0 = 0 dB, VDD = VSS = 1.5 V, RS = 100 kΩ, CL = 30 pF
Lab
1) Simulate the designs from the prelab indicated by the TA. Simulate and perform
design iterations until your circuit operates within specifications. These simulation
results will be included in the final lab report. After the circuit is operating properly,
create a DC input-output characteristic plot and comment on the linear region.
Determine the input offset and add a bias source to the circuit to insure Vout = Vin = 0.
Create frequency response plots, and determine the GBW, PM, p1, and AV0.
2) Layout your final design.
3) Repeat simulations from part 1 on the layout. Be sure parasitic capacitances from the
layout are included.
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Lab 7: Differential Pairs
Objective
Design, simulate, and layout various differential pairs used in different types of
differential amplifiers such as operational transconductance amplifiers and operational
amplifiers.
Introduction
Differential pairs are the final set of basic circuit elements that will be discussed
in this lab course. These circuit elements are used as the input stages of operational
amplifiers and operational transconductance amplifiers, common-mode feedback circuits,
and analog multipliers. As with the other fundamental building blocks, a good understanding of differential pairs is required for successful analog circuit design.
A differential pair consists of two well-matched, source-coupled transistors as
shown in Figure 7-1. An input voltage between the two gate terminals produces an output current in the drain terminals.
IoVi-

Io+

M1

M2

Vi+

Common

Figure 7-1: Basic differential pair
The most common application for a differential pair is the differential amplifier.
Figure 7-2 shows the basic differential amplifier. It consists of a differential pair which is
biased by the tail current source Itail. Resistor Rtail models the output resistance of a real
current source. Load resistors RD1 and RD2 allow the amplifier to develop an output
voltage. The output voltage can be differential or single-ended. A differential output is
developed between the two output terminals, while the single-ended output is taken
between one output and ground.
The task of the differential amplifier is to amplify the difference between its two
input signals. The signals can be decomposed into two components. The first component
is called the differential-mode voltage vDM and is given by:
vDM = v1 – v2
The second component is called the common-mode voltage vCM and is given by:
v CM =

v1 + v 2
2
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VDD
RD1

RD2
VOD
M1

Vi-

M2

Vi+

Rtail

Itail

VSS

Figure 7-2: Basic differential amplifier
Assuming M1 and M2 are in saturation, neglecting channel length modulation, and
assuming perfectly matched transistors, the large signal characteristics can be analyzed as
follows:

v DM = v G1 − v G2 = v GS1 − v GS2 =

2I D1
2I D2
−
β1
β2

I tail = I D1 + I D2
where β = KP ⋅ (W L ) . Assuming that β = β1 = β 2 and combining both equations, two
equations describing the drain currents are obtained.
I D1

I
I  β ⋅ v 2DM β ⋅ v 4DM 
= tail + tail 
−

2
2  I tail
4 ⋅ I 2tail 

I D1

I tail I tail  β ⋅ v 2DM β ⋅ v 4DM 
−
−
=


2
2  I tail
4 ⋅ I 2tail 

1

1

2

2

These relationships are valid only for
v DM ≤

2 ⋅ I tail
β

and for M1 and M2 in saturation. This means that for vDM greater than or equal to the
above expression, then only one of the transistors is conducting and the other is off.

54

I
I tail
ID1

ID2
slope=-gm

slope=gm

2

2

vDM

KP  W 
 
I tail  L 

Figure 7-3: Normalized large signal transconductance characteristic of a MOS
differential amplifier
The desired behavior of the differential amplifier is to amplify the differentialmode voltage and attenuate the common-mode voltage. The differential gain ADM of an
amplifier with a differential output is defined as:

A DM =

v OD
v DM

where vOD is the differential output voltage. For a single-ended differential amplifier, the
gain is defined as
A DM =

v OS
v DM

where vOS is the single-ended output voltage. For an amplifier with a differential output,
the common-mode gain is defined as:

A CM =

v OD
v CM

and for an amplifier with a single-ended output, the common-mode gain is defined as:

A CM =

v OS
v CM

For a symmetrical amplifier such as the fully-differential amplifier, that is an
amplifier with a differential output and a differential input, the common-mode voltage
gain will be zero if the differential pair is perfectly matched. Due to mismatches in the
differential pair or in the loads, a common-mode input voltage can cause a differential
output voltage. A figure of merit for differential amplifiers is the common-mode
rejection ratio (CMRR). The CMRR is defined as the ratio of the differential gain and
common-mode gain:
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A
CMRR = 20 ⋅ log10  DM
 A CM






The input common-mode voltage is limited in magnitude. The inputs must not
force any of the transistors out of saturation. The limitation on the common-mode
voltage creates a common-mode voltage range for the amplifier. When the commonmode voltage increases above the upper limit, the transistors in the differential pair will
leave the saturation region and enter the linear region. If the common-mode voltage
decreases below the lower limit, then the transistors in the tail current source will be
forced out of saturation. The common-mode voltage range can be found by considering
the saturation voltages for differential pair transistors and current source transistors.
Remember, for a transistor to be in saturation:
VDS(SAT) = VGS − VT =

2I D
W
KP ⋅
L

The output voltage range is also limited. For a single-ended amplifier with
symmetrical power supplies, the magnitude of the output signal is limited to the supply
rail:

VOS ≤ VDD
However, for a fully-differential amplifier the output signal can be twice this
amplitude. Each output can swing to a supply rail, giving a differential output voltage
that is twice as large as either rail. As with all amplifiers, another limit on the output
voltage swing is the allowable distortion. An output signal swing which comes within
200 mV of the supply rails may have 10% THD; however, a signal which comes within
500 mV may have only 1% THD in the same circuit. The output voltage range is dictated
by the distortion requirement.
The input-output characteristic curves of the differential amplifier are shown in
Figure 7-4. The region where the input is approximately zero volts is linear. The size of
the linear region is determined by the transistor sizes. Decreasing the transistor sizes will
decrease the transconductance and increase the size of the linear region.
The amplifier also has an input and output impedance. The differential input
resistance and the common-mode input resistance are large for MOSFET differential
amplifiers. The differential input resistance is the resistance between the two input
terminals. The common-mode input resistance is the resistance measured between the
two interconnected inputs and ground.
The output impedance can also be measured in two different ways. For fully
differential amplifiers, the differential output resistance is the resistance between the two
output terminals. For single-ended amplifiers, the common-mode output resistance is the
resistance measured between the output and ground.
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V0
+V0(max)

small W/L
linear region
Vin=Vi+-Vilarge W/L
-V0(max)

Figure 7-4: Input-output characteristic curves for a differential amplifier
Another figure of merit for the differential amplifier is its power supply rejection
ratio (PSRR). This ratio indicates the effect of power supply variations or noise on the
output voltage. For full-differential amplifiers with perfect matching in the differential
pair and load, the PSRR is zero. PSRR is given by:

 A dm 

PSRR + = 20 ⋅ log10 

v
v
o
DD


 A dm 

PSRR − = 20 ⋅ log10 

v
v
 o SS 
The slew rate is a measure of how quickly the output of the differential amplifier
can change in response to an instantaneous rail-to-rail (large-signal) change in the input
voltage.
Due to process variations, the differential pair will not be perfectly matched. As a
result, for equal input voltages, the drain currents will not be equal. Also, if the load is
asymmetrical, then a non-zero output voltage will exist. The voltage at the input which
forces the output voltage to zero is called the input offset voltage.
Design Description
This lab consists of the design of two single-ended differential amplifiers. Figure
7-5 illustrates the simple differential amplifier. This circuit consists of a differential pair
biased by a simple current mirror. The active load is a PMOS current mirror.
Differential Gain
The differential gain of this circuit is given by:
A DM = G m ⋅ R out = g m1,2 ⋅ (rds2 || rds6 )
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VDD
M5

M6

Rbias
Vi+

M1

M2
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Vi-

CL

Itail
M3

M4

VSS

Figure 7-5: Simple differential amplifier
Slew Rate
The biasing current and the amount of load capacitance determine the slew rate.
The slew rate is given by:

SR =

I tail
CL

GBW and Dominant Pole
Since the output node is a high-impedance node, the dominant pole is located at:
p1 =

1
R out ⋅ C L

The gain-bandwidth product is then given by:

GBW = A DM ⋅ p1
Common-Mode Voltage Range
As mentioned previously, the common-mode voltage range is the range of input
voltages which keep the current-source and active load transistors in saturation. The
common-mode voltage range is determined by the sizes of the transistors. To increase
the common-mode voltage range, the sizes of the transistors must be increased. The
common-mode voltage range is given by:
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V

V

V

DS, sat1,2
DS, sat5,6

DS,sat4
 



2I tail
I tail
I tail
VSS +
+
+ VTN < Vin(CM) < VDD −
− VTP + VTN
W
W
W
5,6
KN
3,4
K N 1,2
KP
L
L
L

Common Mode Gain
To design for common mode, we can no longer assume that there exists an AC
signal ground at the source of M1 and M2. This current source must be substituted by a
resistor of value equal to the output resistance of the current mirror. To help in the
development of the design equations, Figure 7-6 is used. From this figure, the commonmode voltage can be found by:
i d = g m v gs = g m (v CM − v S )
v S = 2i d ro4

 1
v CM = i d 
+ 2ro4  ≈ 2i d ro4

 gm
Following a similar approach, the output voltage is given by
v out ≈ −i d

1
g m6

The common-mode gain is then given by:
A cm

1
v out
g m6
1
=
≈−
=−
v CM
2ro4
2g m6 ro4

As can be seen from this equation, the CMRR can be improved by increasing the output
impedance of the tail current.
CMRR = 20log10

A dm
= 20log10 g m1,2 (rds2 || rds6 )2g m6 ro4
A cm
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VDD
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ro4

VSS

Figure 7-6: Differential amplifier used to determine CMRR
Cascode Differential Amplifier
The second differential amplifier is shown in Figure 7-7. This circuit utilizes lowvoltage cascode current mirrors as the current source and active load. Design equations
for this structure are the same as the previous structure except that the output impedance
of the amplifier and current source are now larger. This will increase differential-mode
gain while decreasing common-mode gain, thus a vastly improved CMRR. The main
drawback of this circuit is a reduced input common-mode range and output swing
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VDD
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M2
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Figure 7-7: Cascode differential amplifier
Prelab
The prelab exercises are due at the beginning of the lab period. No late work is accepted.
1) Compare the two single-ended differential amplifiers discussed in this lab. Rate the
differential gain, common-mode gain, power supply voltage, CMRR, and commonmode input range. Include the expressions for each design specification.
2) Design the simple differential amplifier in Figure 7-5 to obtain the following
specifications:
Slew Rate

10 V/μs

Gain-Bandwidth Product

2.5 MHz

Common-Mode Voltage Range

1.75 V

Power Supply

VDD = -VSS = 1.5 V

Load Capacitance

10 pF
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3) Design the cascode differential amplifier in Figure 7-7 to obtain the following specifications:
Slew Rate

10 V/μs

Gain-Bandwidth Product

2.5 MHz

CMRR

> 80 dB

Power Supply

VDD = -VSS = 1.5 V

Load Capacitance

10 pF

Lab
1) Simulate the design from the prelab indicated by the T.A.
Measure and plot:
•

Common-mode range

•

Differential-mode gain

•

Common-mode gain

•

CMRR

•

GBW

•

Dominant pole p1

•

Slew rate

Use any analysis necessary to obtain the most accurate measurements. Include these
results in the lab report.
2) Layout the final design. Repeat above measurements. Be sure to include parasitic
capacitance in the layout extraction. Include these results in the lab report.

62

Lab 8: Operational Transconductance Amplifiers
Objectives
Design, simulate, and layout an operational transconductance amplifier.
Introduction
The operational transconductance amplifier (OTA) is a basic building block of
electronic systems. The function of a transconductor is to convert an input voltage into
an output current. The transconductance amplifier can be configured to amplify or
integrate either voltages or currents. The versatility of an OTA allows its use in many
electronic systems such as filters, analog-to-digital converters, and oscillators. An OTA
is also used as the core amplifier for an operational amplifier (discussed in Lab 9). The
operational transconductance amplifier is an essential element of many analog systems.
The symbol for a single-ended OTA is shown in Figure 8-1. The amplifier has
two voltage inputs and a single current output. Fully-differential versions are available
and are commonly used in integrated circuits.
The output current of an OTA is proportional to the difference between the input
voltages. The relationship between the input voltages and output current is given by:
I O = G m ⋅ (Vi + − Vi − ) .

Vi+
Vi-

+
Gm
Figure 8-1: OTA symbol

The input-output characteristic for an OTA is shown in Figure 8-2. Notice that
this characteristic is similar to the input-output characteristic for the differential amplifier.
For a given maximum output current, the width of the OTA’s linear region is inversely
related to the magnitude of the transconductance; the larger the linear region, the smaller
the transconductance.
The input and output resistance must be large in an OTA. Infinite input
impedance allows maximum transfer of the source voltage to the input of the OTA.
Maximum transfer of output current to the load occurs when the output resistance is
infinite.
The circuit diagram for a basic OTA is shown in Figure 8-3. Notice that this is
the differential amplifier from Lab 6.
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I0
+I0(max)
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Vi+-Vi-
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-I0(max)

Figure 8-2: Input-output characteristic for an OTA
VDD
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M6
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Vi+
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Vi-
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Itail
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Figure 8-3: Differential amplifier used as an OTA
A quick analysis of this amplifier shows the transconductance is given by:
Gm = gm1,2
The input resistance is large due to the inputs being at the gate terminals of the
MOS differential pair. Notice that the output resistance is also large:
Rout = rds2 || rds6
The gain-bandwidth product is given approximately by:
GBW =

g m1,2
CL
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An improvement of the differential amplifier of Figure 8-3 is to use self-biased
loads. The circuit in Figure 8-4 is called a symmetric OTA or three current-mirror OTA.
This circuit is constructed from all the basic elements discussed in the previous labs. The
input stage is a differential pair (Lab 7). The sub-circuits composed of M1,3 and M2,4 are
self-biased inverters (Lab 6). Transistors M3,5, M4,6, M7,8, and M9,10 are simple currentmirrors (Lab 5).
VDD
M5

M3

M4

A1

M6
A2

Io

Rbias
Vi-

M1

M2

CL

Vi+

B
Itail
M9

M10

M7

M8

VSS

Figure 8-4: Three current-mirror OTA
When designing the symmetrical OTA, transistors M1 = M2, M3 = M4, M5 = M6,
and M7 = M8. This reduces the number of designable parameters to four transistor sizes
and the tail current. An analysis of this amplifier shows the transconductance is given by:
G m = β ⋅ g m1,2

where

β=

g m 5, 6
g m 3, 4

The input resistance is large due to the MOS input stage. The output resistance is
given by:
Rout = rds6 || rds8
The gain-bandwidth product is given approximately by:
GBW = β ⋅

g m1,2
CL
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Analysis shows that the symmetric OTA has a larger transconductance, slew rate,
and GBW than the OTA of Figure 8-3. These specifications are made larger by
increasing β.
Design Description
The design of an OTA begins with a consideration of the design specifications.
The typical design considerations for an OTA include transconductance, slew rate, output
resistance, GBW, noise, phase margin, power dissipation, and output loading. The
transconductance of the symmetric OTA was listed previously and is repeated here for
convenience:
G m = β ⋅ g m1,2 = β ⋅ I tail ⋅ K N ⋅

W
1,2
L

where
β=

g m5,6
g m3,4

In the above equation, notice that the DC current in transistors M5,6 is β times
larger than the currents in transistors M3,4. The transconductance can be set by the tail
current source, current mirror ratio, or size of the input transistors. The transconductance
is usually the most important parameter, and it is fortunate that it can be determined by
several parameters. Automatic tuning circuits sometimes vary the bias current in order to
adjust the transconductance to the desired value.
The slew rate of the OTA is given by:
SR = β ⋅

I tail
CL

Notice the slew rate is larger than the slew rate of the differential amplifier. The
increased slew rate comes with the disadvantage of an increase in current (power)
consumption. The current drawn from the power supply (not including bias current
source) is given by:
I DD =

1
1
1
1
I tail + I tail + β ⋅ I tail + β ⋅ I tail = (β + 1)I tail
2
2
2
2

The output resistance was listed above and is repeated below as:
Rout = rds6 || rds8
The gain-bandwidth product is given by:

1
GBW = A V0 ⋅ p1 = (G m ⋅ R out )
 R out ⋅ C L

 Gm
 =
 CL

Another design consideration is noise. The noise performance is improved when
the voltage gain of the first stage is large. The voltage gain of the first stage is given by:
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W
1,2
KN L
1
A V1 = g m1,2 ⋅
=
g m3,4
K P W 3,4
L

The phase margin is a measure of stability for the amplifier. In most cases, the
load capacitance is much larger than the capacitance at the other nodes. When this is the
case, the operational transconductance amplifier has a dominant pole at the output node
and two non-dominant poles at the other two nodes. Due to the symmetric behavior at
the input stage, the amplifier also has a right-half plane zero. For most symmetric OTA
designs, the non-dominant poles and zero are much larger than the gain-bandwidth
product and degrade the phase margin by less than 10º each. This gives a typical phase
margin of greater than 60º. The transfer function of the OTA is given by:
A V 0 ⋅ ρ1ρ2ρ3
(s − z )
z
H(s ) =
(s + ρ1 )(s + ρ2 )(s + ρ3 )
where:
p1 - is the dominant pole, located at the output node: p1 =

1
R out CL

p2 - is the non-dominant pole, located at nodes A1 and A2:

p2 =

g
1
≈ m 3, 4
R ACA
CA

p3 - is the non-dominant pole, located at node B: p3 =

1
g
≈ m7
R BC B C B

z - is the zero due to the pole-zero doublet formed by the symmetric input stage:
z = 2 p2
The phase margin is thus given by:
 GBW 
 GBW 
 GBW 

 − tan −1 
 − tan −1 
PM = 1800 − tan −1 (A V 0 ) − tan −1 
 p2 
 2p 2 
 p3 
 GBW 
 GBW 
 GBW 

 − tan −1 
 − tan −1 
≈ 900 − tan −1 
p
2
p
p
2 
 2 

 3 
The above design description shows that many performance figures are inversely
related. For example, increasing slew rate results in an increase in power dissipation.
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Prelab
The prelab exercises are due at the beginning of the lab period. No late work is accepted.
1) Design the three current mirror OTA of Figure 8-4 to obtain the following
specifications:
Gm:

500 μA/V

Slew Rate:

SR > 10 V/μs

CL:

20 pF

Power:

PD < 1 mW (not including bias current source)

Power Supply:

VDD = -VSS = 1.5 V

Lab
1) Simulate the design from the prelab. Measure the transconductance vs. frequency,
slew rate, power consumption, voltage gain vs. frequency, dominant pole frequency,
phase margin, and gain-bandwidth product. Use any analysis necessary to obtain the
most accurate measurements. These simulation results will be included in the final
lab report.
2) Create three cell views for your OTA: symbol, schematic, and layout. Layout your
final design and use good layout techniques. In your lab report indicate which
transistors should be matched. Extract the layout and repeat simulations from part 1.
Be sure to include parasitic capacitances in the extraction.
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Lab 9: Two Stage Miller OTA
Objective
Design, simulate, layout, and test a two-stage operational amplifier.
Introduction
The operational amplifier (opamp), like the operational transconductance
amplifier, is an essential component of analog system design. Integrated circuit design,
as well as board level design, heavily uses operational amplifiers. This component is
basically a high-gain voltage amplifier. Opamps are used in many analog systems such
as filters, regulators, and function generators. This rudimentary device is also used to
create buffers, logarithmic amplifiers, and instrumentation amplifiers. The opamp can
also function as a simple comparator. Knowledge of operational amplifier function and
design is important in analog design.
The symbol for an operational amplifier is shown in Figure 9-1. The basic device
has two inputs and a single output. A fully-differential version of the opamp is often
used in high performance integrated circuit designs.
ViVi+

+

Vo

Figure 9-1: Operational amplifier symbol
The operational amplifier functions as a voltage amplifier.
between the input and output voltage is given by:

The relationship

Vo = AV0 ∙ (Vi+ - Vi-)
The amplifier has a high voltage gain (AV0 > 1000 for CMOS opamps). Due to
the high gain, the linear region is very narrow. Figure 9-2 illustrates the typical inputoutput characteristic for an operational amplifier used with and without feedback. The
open-loop (without feedback) plot shows the linear region is only a few millivolts wide.
From Figure 9-2, the open loop input-output characteristic is clearly nonlinear.
Vo
+Vo(max)
open-loop

closed-loop
Vi+-Vi-

-Vo(max)

Figure 9-2: Input-output characteristic for an opamp
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Due to the high gain and limited linear region, the opamp is commonly used in a
negative feedback loop. Figure 9-2 shows also the input-output characteristic when the
amplifier is used with feedback. Notice the closed-loop linear region consists of almost
the entire input voltage range. The application of feedback reduces the non-linearity, but
also reduces the voltage gain.
The simplest operational amplifier is the differential amplifier studied in Lab 7.
This amplifier can be improved by adding a second stage. The second stage is an
inverting amplifier with a current-source load. The two-stage amplifier shown in Figure
9-3 is referred to as a Miller OTA.
VDD
M3

M4
M8

Ibias
Cc
Vi-

M1

M2

Vo
CL

Itail

M6

M5

Vi+

RL

M7

VSS

Figure 9-3: Miller OTA
The Miller OTA has a low frequency voltage gain of:
AV0 = Gm ∙ (Rout || RL)
The transconductance is given by:
Gm=

g m1, 2 ⋅ g m8
g o2 + g o4

The output resistance of the two-stage opamp is given by:
Rout = rds7 || rds8
Design Description
The two-stage amplifier can be modeled as a cascade arrangement of two
amplifiers. Figure 9-4 illustrates the sequence of amplifiers. The first stage is a
differential amplifier. This stage produces an amplified version of the difference in input
signals. This stage determines the CMRR, slew rate, and other performance specifications
determined by the differential amplifier described in Lab 7.
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Av > 1
Vi-

Av >> 1

+

Vi+

Vo

Input
Stage

Gain
Stage

Figure 9-4: Three-stage operational amplifier model
The second stage is an inverting amplifier. The purpose of this stage is to provide
a large voltage gain. The gain stage and the input stage create two poles which affect the
stability of the system. Usually some form of compensation is required to assure the
amplifier is unity-gain stable. Additional gain stages can be employed to increase the
gain, but this increases the stability problems and requires complex compensation
techniques. Refer to Lab 6 for details on the inverting amplifier performance
specifications.
The frequency response of an operational amplifier will be analyzed with help
from a macromodel of the structure. Figure 9-5 shows a macromodel of the opamp. The
capacitor Cin models the input capacitance of the opamp, which is due mostly from gateto-source capacitance. The subcircuit consisting of GmA, RA, and CA model the gain and
frequency response of the input stage. The capacitance CA includes the input capacitance
of the second stage and the output capacitance of the first stage. The components GmB,
RB, and CB model the second stage. The load capacitor and resistor are also included in
RB and CB.

Vin =Vi+ -Vi-

Cin

VA
-

+

+

+
RA
GmA VA

CA

VB
-

RB
GmB VB

Figure 9-5: Operational amplifier macromodel
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CB

Vout
-

The transfer function of the macromodel is given by:
GmAGmB
AVo ⋅ ρ1 ρ 2
C AC B
=
H (s ) =
(s + ρ1 )(s + ρ 2 ) 
1 
1 
 s +
 s +

R AC A 
RB C B 

This transfer function assumes the source resistance is zero ohms. Notice the two
poles are approximately equal. The capacitors CA and CB are dominated by gate-to-source
capacitance, and RA and RB are the parallel connected small-signal drain-to-source
resistance. The pole-zero plot of this transfer function is illustrated in Figure 9-6.

p2 p1

Figure 9-6: Pole-zero diagram for uncompensated opamp
Due to the two poles being located close together, the system is unlikely to be
unity-gain stable due to the large DC gain of an operational amplifier. Clearly, some
form of compensation is required. The modified macromodel shown in Figure 9-7 uses
capacitor CC to compensate the frequency response of the opamp by splitting the distance
between the two poles.
CC

+
Vin =Vi+ -Vi-

Cin

VA
-

+

+
RA
GmA VA

CA

VB
-

RB
GmB VB

CB

Vout
-

Figure 9-7: Operational amplifier macromodel with compensation capacitor CC
Assuming RA is large, that is:
R A ≈ R B and R A >>

1
G mB

and CA is small:
C B >> C A and C C >> C A
and using the results obtained from the inverting amplifier lab, the transfer function for
the operational amplifier with the compensation capacitor is:
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G mA  G mB 
A V 0 ⋅ ρ1ρ 2

s −
(s − z )
C B 
C C 
z
H C (s) =
=
(s + ρ1 )(s + ρ 2 ) 
 G mB
1
 s +
 s +
G
R
R
C
CB
mB
A
B C 






These simplifying assumptions hold because capacitance CB will include the
capacitance of the load, and the compensation capacitance CC can be chosen to be the
size of the load capacitor. Also, for the two-stage OTA, capacitance CB will include the
load capacitance CL.
With the transfer function in factored form, we can find the open-loop DC gain,
poles, and zero of the compensated opamp are given by:
AV 0 = GmA GmB R A RB

ρ1 =

−1
−1
=
GmB RB CC R A
AV 2 CC R A

ρ2 =

− GmB
CB

z=

GmB
CC

GBW =

GmA
CC

Notice the addition of the compensation capacitor CC caused the poles to separate.
One pole moved closer to the origin by a factor of AV2 = GmB ∙ RB, while the other pole
moved away from the origin by a factor of AV2. This compensation technique is called
“pole splitting”. The pole-zero plot of this transfer function is illustrated in Figure 9-8.
Also, notice the creation of a zero as a result of the transition path created by the
capacitor.

p2

p1

z1

Figure 9-8: Pole-zero plot for a compensated opamp
Using the compensated opamp in a feedback loop produces the following transfer
function:
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A C (s ) =

=

=

H C (s )
1 + H C (s ) ⋅ β

A 0 (s − z )
(s + ρ1 ) (s + ρ 2 ) + A 0 β (s − z )


G
1
s 2 + 
+ mB
 G mB R A R B C C C B

 G 
A 0  s − mB 
CC 



G
G G
1
+ mA mB
+ mA β  s + 
CB 
CBCC
 R ACBR BCC


β 


where

A0 =

G mA
CB

The closed-loop transfer function using the compensated amplifier can be
approximated by:

A C (s ) =

 G mB 

 s −
C C 

G G

G
+ mA β  s +  mA mB
CB 
 CBCC
G mA
CB

G
s 2 +  mB
 CB


β 


The effect of the above simplification on the system is to assume the dominant
pole is at the origin. Notice that when the system is in open-loop (β = 0), the transfer
function reduces to:

A C (s ) =

 G mB
 s −
CC

 G 
s  s + mB 
CB 


G mA
CB





The factor β varies the position of the dominant pole from the origin to the
neighborhood of the non-dominant pole. Figure 9-9 illustrates the effect of feedback on
the frequency response.
H(s)

β=0

β = 0.5

β =1

f
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Figure 9-9: Closed-loop frequency response
To assure the feedback system is unity-gain stable (β = 1), the phase margin must
be examined. The phase margin is the amount of phase before phase inversion (180º) at
the unity gain frequency. The expression for the phase margin is given by:

ω 
ω 
 − tan −1  0 dB  − tan −1  0 dB 
 z 

 p2 
 GBW 
 GBW 
 GBW 
 − tan −1 
 − tan −1 
= 180 0 − tan −1 

 z 
 p1 
 p2 

ω
PM = 180 0 − tan −1  0 dB
 p1

 GBW 
 GBW 
 − tan −1 
= 180 0 − tan −1 (A V 0 ) − tan −1 

 z 
 p2 
 GBW 
 GBW 
 − tan −1 
≈ 90 0 − tan −1 

 z 
 p2 

The phase margin is improved by moving the non-dominant pole and zero to
higher frequencies away from the unity-gain frequency. The phase margin can also be
improved by using compensation techniques which place the zero in the left-half plane.
The slew rate is determined by the compensation capacitance and the tail current:

SR =
below:

I tail
CC

The performance characteristics of the two-stage amplifier are summarized
A V0 = g m1,2 g m8 (rds2 || rds4 ) (rds7 || rds8 || R L )
ρ1 =

g m8 (rds7 || rds8

ρ2 =
z=

− g m8
CL
g m8
CC

GBW =
SR =

−1
|| R L )C C (rds2 || rds4 )

g m1,2
CC
I tail
CC

 GBW 
 GBW 
 − tan −1 
PM ≈ 90 0 − tan −1 

 z 
 p2 
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Monte Carlo Analysis
Monte Carlo analysis provides an accurate and powerful method for parametric
yield estimation. The principle of Monte Carlo analysis can be defined as the generation
of circuit figure-of-merit distributions as a function of statistically varying device model
parameters that accurately reflect manufacturing process variations.
With Monte Carlo analysis, you can generate and save statistical information
about a circuit’s temperature and geometry-dependent performance characteristics. The
mathematics supporting this Monte Carlo method proves that the probability distribution
of the simulated results will be statistically the same as the actual measurements of a real
circuit that has been fabricated.
These are the steps involved in Monte Carlo simulation using Analog Artist:
1) Assign statistical parameters to devices in the model file.
2) Setup the simulation environment and run a normal analog simulation.
3) Open Monte Carlo window
4) Define the expressions for Monte Carlo analysis using the calculator.
5) Add expressions to the Monte Carlo window.
6) Define the Monte Carlo simulation parameters.
7) Start the analysis.
8) Use the statistics functions to display and analyze the results.
There are two basic statistical distribution functions that you can apply to device
parameters:
• Uniform
• Gaussian
The uniform distribution is defined with a mean value and a tolerance that defines
the minimum and maximum values. Statistically, all values between the minimum and
maximum values are equally likely to occur. Figure 9-10a shows a plot of a uniform
distribution.
The Gaussian distribution is defined with a mean and a standard deviation.
Statistically, values about the mean are more likely to occur than values within the tails.
Almost all values fall within 3 standard deviations of the mean. Figure 9-10b shows a
plot of a Gaussian distribution.

A=mean-(mean*tol)
C=mean+(mean*tol)
A

mean

− 3σ − 2σ − σ

C

(a)

µ

(b)
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σ

2σ

3σ

Figure 9-10: a) Uniform distribution
b) Gaussian distribution
The syntax to include the statistical analysis in the model file is:
UNIFORM(mean,tol,seed)
GAUSS(mean,std_dev,seed)
For example, if you want to vary the threshold voltage by ±15 % using a Gaussian
distribution, you would need to calculate what standard deviation to use. Since variations
will fall within three standard deviations, the standard deviation needs to be 5 % of the
mean. Assuming that the original threshold voltage in the model file is 0.7 V, then the
standard deviation will be 0.035 V. Thus in the model file, replace the line:
VTH0=0.7 &
with:
VTH0=GAUSS(0.7,0.035,1) &
The most common analysis modes to perform are:
•

Random variations

•

Random variations with mismatch

With random variations, the parameters track exactly. All devices that share the
same model file share the same model statement in the netlist. With random variations
with mismatch, the system creates a separate model statement for each device.
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Prelab
The prelab exercises are due at the beginning of the lab period. No late work is accepted.
1) Design the operational amplifier of Figure 9-3 to obtain the following specifications:
AV0

> 60 dB

CMRR

> 70 dB

GBW

> 1 MHz

PM

> 45º

Output Swing

> 1.5 V

CL

30 pF

PD

< 500 µW

Lab
1) Simulate the design from the prelab. Adjust transistor sizes until all specifications are
met. Provide plots of frequency response, CMRR, PSRR+, PSRR-, and transient
response. Include the slew rate, phase margin, gain-bandwidth product, and power
dissipation in your report.
2) Layout your final design using good layout techniques. Include the “net-lists match”
page in your report. Include the plots and data from part 1. Be sure to include
parasitic capacitances in your extraction.
3) Run a Monte Carlo simulation on the opamp design. Vary the parameters VTH0 and
U0 by 20% with a Gaussian distribution. Be sure to run this simulation with process
variations and mismatch. Generate a histogram of the following parameters:
•

GBW

•

p1

•

PM

•

AV0

Comment on the impact of process variations and mismatch on each parameter.
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