
 

 

 

 

 

 

 

Lab Reference Manual 
 

ECEN 326 – Electronic Circuits 

 

 

 

 

 

 

 

 

 

Texas A&M University 

Department of Electrical and Computer Engineering 
 

 

 



 2

Contents 
 

1. Circuit Analysis in PSpice       3 

    

 1.1 Transient and DC Analysis      3 

 

 1.2 Measuring THD       6 

 

 1.3 Voltage Swing Analysis      8 

 

 1.4 Analysis of Input Resistance      9 

 

 1.5 Analysis of Output Resistance     11 

 

 

2. Lab Measurements        13 

 

 2.1 Circuit Construction and DC Analysis    13  

 

 2.2 Measuring THD with NI ELVIS     18 

 

 2.3 Measuring THD with HP Oscilloscope    23 

 

 2.4 Measuring Voltage Swing      27 

 

 2.5 Measuring Input and Output Resistance    28 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 3

1.  Circuit Analysis in PSpice 
 

1.1 Transient and DC Analysis in PSpice 
 

Start by placing the circuit components in the schematic screen.  Bring up the part 

browser window as shown in figure 1 by going to “Draw → Get 
ew Part…”, by 

clicking on the button with the binoculars next to the parts list drop down menu, or by 

clicking Ctrl+G.  See figure 1.1. 

 

 
Figure 1.1: PSpice showing the Parts Browser window. 

 

 

Select the appropriate part from the list on the left side of the window and click the 

“Place” button.  Left click to place the part and right click to de-select.  To change the 

values of a part, double click the part to bring up a dialog box.  After editing a value, 

click the “Save Attr” button to save the entered value.  (Be sure to place a ground node so 

that PSpice will have a reference voltage). 

 

Use the shortcut key Ctrl+R to rotate a part counterclockwise and Ctrl+F to flip the part 

to its mirror image.  To wire components together, click on the thin pencil button to draw.  

To name a node, double click the wire to bring up a dialog box.  Name the signal input 

voltage “vin” and the output voltage “vout”. 

 

For input stimulus, use the component called “VSIN”.  Double click the component to 

bring up the attributes.  Set DC to 0, VOFF to 0, and AC to 1 (this allows for frequency 
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domain analysis).  VAMPL is the amplitude of the time domain input waveform, and 

FREQ is the operating frequency. 

 

To set up the analysis, go to “Analysis → Setup…” or click on the blue and grey setup 

button to bring up the Analysis Setup window.  Check the transient box to enable analysis 

in the time domain.  Click on the “Transient…” button to edit the time domain and 

Fourier parameters.  Set the “Final Time” field to show five complete cycles.  So for an 

operating frequency of (1/T) Hz, the period is T seconds.  Set the “Final Time” to 5T.  

Set the “Print Step” and “Step Ceiling” fields to a value between T/100 and T/1000 

seconds.  See figure 1.2. 

 

 

 
Figure 1.2: Transient Analysis setup. 

 

 

To simulate the circuit, click the yellow simulate button or go to “Analysis → Simulate”.  

Click the bold “V” and “I” buttons to display the DC bias values on the schematic.  See 

figure 1.3.  

 

Open the simulation results window (it should pop-up automatically when the simulation 

is run).  Click “Trace → Add Trace…” or the “Add Trace” button to bring up a window 

to select which values are plotted.  Click on “V(vout)” and “V(vin)” and press “OK”.  The 

transient waveforms are displayed in the results window.  See figure 1.4. 
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Figure 1.3: Schematic with DC bias values shown. 

 

 

 

 
Figure 1.4: Transient analysis showing input and output waveforms. 
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1.2 Measuring THD in PSpice 
 

In the schematic window, go to “Analysis → Setup…” or click on the blue and grey setup 

button to bring up the Analysis Setup window.  To determine Total Harmonic Distortion 

or THD, check the “Enable Fourier” box, set the “Center Frequency” to the operating 

frequency, set the “
umber of Harmonics” to 5, and set the “Output Vars” field to 

“v(vout)” where “vout” is the name of the node at the circuit output.  See figure 1.2 in 

“Transient and DC Analysis in PSpice”. 
 

Simulate the circuit, and open the simulation results window.  To display the frequency 

components of the waveforms, click on the “FFT” button or go to “Trace → Fourier”.  

Make the vertical axis log scaled by clicking on the “Log Y Axis” button or by going to 

“Plot → Axis Settings…” click on the Y-Axis tab and change the scale to “Log”.  See 

figure 1.5. 

 

 
Figure 1.5: Harmonic Distortion 

 

To view the numerical THD results, go to “View → Output File” and scroll all the way to 

the bottom.  The Total Harmonic Distortion is given in percent.  (Be careful to check the 

exponent because it is very easy to mistake having THD of 2.0% when it is actually 

20%!)  See figure 1.6. 

 

To find the input voltage for 1% THD, go back to the schematic window and change the 

amplitude of the VSIN component, re-run the simulation, then go back and check the 

THD in the output file.  Make any adjustments and re-simulate until the THD is 1%.  

Follow the same procedure for THD of 5%. 
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Figure 1.6: Output file showing THD and the distortion contribution of each harmonic 
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1.3 Voltage Swing Analysis in PSpice 
 

To verify the output voltage swing, give the transient input voltage a relatively large 

value so that the output will be hard clipped.  Run the simulation and examine the 

transient waveform to verify that there is hard clipping of the output signal.  The 

waveform clipping defines the upper and lower values of the voltage swing range.  See 

figure 1.7. 

 

 
Figure 1.7: Analysis of output voltage swing.  The swing of this waveform is 1.6V 0-to-peak. 
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1.4 Analysis of Input Resistance in PSpice 

 
To verify the input resistance, open the schematic window and go to Analysis Setup.  

Check the box next to the “AC Sweep…” button, and then click on the button.  In the 

window that opens, set a frequency range that includes the operating frequency.  See 

figure 1.7. 

 

 
Figure 1.7: Setup for AC analysis. 

 

Run the simulation, and then go to the results window.  If you are also running a transient 

analysis as is being done in figure 1.7, you will see a window that allows you to choose 

AC or transient analysis.  Choose AC, and then open the “Add Trace” window.  To verify 

input resistance, select the voltage at the input node divided by the current generated by 

the input voltage source.  Since input resistance is defined as Vin / Iin, the y-axis of the 

plot directly gives the value of the input resistance.  See figure 1.8. 
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Figure 1.8:  AC analysis to determine input resistance. 
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1.5 Analysis of Output Resistance in PSpice 
 

Output resistance analysis is much the same as that of input resistance except that the AC 

input voltage must be set to 0 V, a voltage source must be connected to the output node, 

and the load impedance should be removed.  Select AC = 1 for the output source.  See 

figure 1.9. 

 

 
Figure 1.9:  Circuit setup for determining output resistance. 

 

Run the simulation, and then go to the results window.  If you are also running a transient 

analysis, you will see a window that allows you to choose AC or transient analysis.  

Choose AC, and then open the “Add Trace” window.  To verify output resistance, select 

the voltage of the output node divided by the current of the output AC voltage source.  

Since output resistance is defined as Vout / Iout, the y-axis of the plot directly gives the 

value of the output resistance.  See figure 1.10. 



 12

 
Figure 1.10:  AC analysis to determine output resistance. 
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2.  Lab Measurements 
 

2.1 Circuit Construction and DC Analysis 
 

First make sure the power supply to the NI ELVIS prototyping board is turned off (the 

switch on the front of the unit), while the system power is turned on (the switch on the 

back of the unit).  Next, build the circuit that was designed in prelab onto the board.  Note 

that each row of 5 holes is one electrical node (ie., 5 holes in a row are electrically 

connected).  Also, the long vertical columns constitute a single node.  These should be 

used as ground and power supply nodes.  See figure 2.1. 

 
Figure 2.1:  Nodes of a breadboard. 

 

A 1-to-1 center-tapped  isolation transformer should be placed at the circuit input.  

Connect the transformer across a ridge on the breadboard.  The schematic for the 

transformer is shown in figure 2.2.  Note the transformer only isolates the input signal, it 

should not be used for the power supply. 
 

 
Figure 2.2: 1-to-1 transformer schematic 

 



 14

The coupling capacitors should be large enough that their impedance at the operating 

frequency is negligible.  The equation for capacitive impedance is: 

 

Cj
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=  

 

If a coupling capacitor of 100 µF is chosen, then at an operating frequency of 5 kHz: 
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Large capacitors are usually electrolytic.  Electrolytic capacitors have polarity that must 

be observed or the internal dielectric will break down and destroy the capacitor.  

Generally, the two capacitor leads are different in length, with the longer lead connecting 

to the more positive node.  Also, there should be a light stripe with (-) signs painted on 

the side that connects to the more negative node. 
 

 
Figure 2.3:  Circuit layout on NI ELVIS prototyping board with external oscilloscope measuring 

waveforms. 
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Connect a wire from one of the holes next to the +5 V supply located on the bottom left 

of the ELVIS board to a supply node on the circuit.  Similarly, connect a wire from the 

ground supply (located right above the +5 V supply) to a ground node on the circuit.  See 

the bottom of the breadboard in Figure 12. Now turn on the power supply switch located 

on the front of the ELVIS board.  The three green LEDs marked +15 V, -15 V, and +5 V 

should now be lit.  

 

Locate the digital multimeter on the ELVIS board (marked DMM
2
).  See Figure 2.4.  To 

measure current, first switch off the supply power switch on the front of the unit.  

Connect a wire to “CURRENT LO” and another to “CURRENT HI”.  Measuring current 

requires breaking the circuit at the node to be measured and then inserting the multimeter 

wires in the broken connection.  Connect “CURRENT HI” to the side of the broken 

connection with the higher voltage and “CURRENT LO” to the lower voltage.  If the 

wires are connected incorrectly, no damage will occur, but the multimeter will display a 

negative current. 
 

 
Figure 2.4:  The ELVIS board multimeter connections 

 

Go to the computer that is attached to the ELVIS board and launch the NI ELVIS 

software.  When the main interface opens, click the Digital Multimeter, and then click the 

NULL option to calibrate the board.  Click the DC Current button (the button marked 

“A” with the straight lines).  Turn on the ELVIS board power supply.  Record the 

measurement.  See Figure 2.5. 

 

After recording the current, turn off the ELVIS power supply.  Remove the multimeter 

probes from the circuit and reconnect the circuit node the way it was before the 

measurement.  Disconnect the next node to be measured and repeat the same process 

until all required currents are measured. 
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Figure 2.5: DC Current Measurement 

 

To measure voltages, first switch off the supply power switch on the front of the unit.  

Connect a wire to “VOLTAGE LO” and another to “VOLTAGE HI”.  Unlike measuring 

current, voltage measurements require that the circuit not be broken.  Instead, 

measurements are made in parallel to the existing circuit.  Since we are referencing all 

voltage to ground, the “VOLTAGE LO” wire should be connected to a ground node of 

the circuit for all voltage measurements.  Go to the computer and click on the digital 

multimeter window.  Click the DC voltage button (the button marked “V” with the 

straight lines) and then click the NULL option to re-calibrate the meter.  See figure 2.6.  

 

 Turn on the ELVIS board power supply.  To measure the voltage at a node, simply 

connect the “VOLTAGE HI” wire to the node.  To measure another node, just move the 

wire from the first node to the next node to be measured. 
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Figure 2.6:  DC Voltage Measurement 
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2.2 THD Analysis with NI ELVIS 
 
1. Construct the circuit on the NI ELVIS breadboard. 

 

2. Turn on power to NI ELVIS (front and back). 

 

3. Log in to your NOVELL account and start the NI ELVIS software.  The ELVIS 

Instrument Launcher will pop up on the screen.  See figure 2.7. 

 

 
Figure 2.7:  NI ELVIS Instrument Launcher window 

 

 

4. On the ELVIS Instrument Launcher, click on the Function Generator button to bring 

up the Function Generator window (figure 2.8).  Enter the desired operating frequency 

in the text box under the frequency fine tuning knob.  Under “Waveforms”, click on the 

sinusoid button.  Make sure the DC offset is set to zero.  Enter the desired input 

amplitude in the text box under the peak amplitude knob.  The smallest input amplitude 

the NI ELVIS can generate is 10 mV.  If a smaller amplitude is needed, simply make a 

10:1 voltage divider at the input of the 1-to-1 transformer at the input of the circuit.  

See figure 2.9. 

 

 



 19

 
Figure 2.8:  NI ELVIS Function Generator window 

 

 

 
Figure 2.9:  10:1 Voltage divider 

 

 

5. Click on Dynamic Signal Analyzer on ELVIS Instrument Launcher.  The window 

shown in figure 2.10 should pop up. 

 

6. Set the Source Channel parameter to be “ACH0” and Trigger Source parameter to be 

“FGE
 SY
C OUT”. 

 

7. Connect the output of the circuit to ACH0+, and connect ACH0- to ground. 
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8. Hit the “Single” button on the Dynamic Signal Analyzer to get a spectrum plot. 

 

9. The window will display the THD in % under the spectrum plot.  Record this value. 

 

 
Figure 2.10: Distortion Analysis using NI ELVIS Dynamic Signal Analyzer 

 

 

11. Save the Distortion Analysis window to include in the lab report.  To copy a window, 

click on the window and then press “Alt + Prnt Scrn”.  This copies the window to the 

clipboard.  Then paste the picture to the lab document. 
 

 


ote:  The ELVIS board tends to give larger variation of THD than the oscilloscope.  For example, ELVIS 

can give a range of values from 4% to 8% THD for a single input amplitude.  The oscilloscope has fewer 

variations than the ELVIS. 
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2.3 THD Analysis with HP Oscilloscope 
 
1. Construct the circuit on the NI ELVIS breadboard. 

 

2. Connect CH1 of the oscilloscope to the circuit input and CH2 to the output of the 

circuit. 

 

3. Connect the function generator to the input of the circuit and set its frequency to the 

operating frequency (eg. 5 kHz) and the amplitude to the value calculated in the pre-lab 

for the given THD. Examine the transient waveform to verify the circuit is operating 

correctly.  See figure 2.12 for a typical transient waveform. 

 

4. Push the “±” button on the oscilloscope to pull up the function options. See figure 2.11 

for a layout of the oscilloscope control panel. 

 

 

 
Figure 2.11: HP oscilloscope control panel 
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5. In the options on the bottom of the screen, toggle Function 2 to “On”.  Then under 

Function 2, select “Menu”.  See figure 2.12. 

 

 

 

 
Figure 2.12: Setting the FFT function  

 

 

 

 

6. Turn off the transient waveforms by pushing the “1” and “2” buttons on the control 

panel.  This will take away the FFT menu.  Push the “±” button again to bring the FFT 

menu back up. 

 

7. In the FFT options at the bottom of the screen, under “Operand”, toggle to “2”.  Under 

“Operation”, toggle to “FFT”.  Then push the button under “Units/div” to set the 

vertical scale.  When the value under “Units/div” is highlighted, turn the cursor knob on 

the control panel to change the vertical scale so that there is a measurable difference 

between peaks.  A typical value for “Units/Div” is “10.00 dB”.  Then push the button 

under “Ref Levl” to set the absolute scale.  When the value under “Ref Levl” is 

highlighted, turn the cursor knob on the control panel so that the peaks are all above the 

bottom of the screen.  A typical value for “Ref Levl” is “10.00 dBV”.  See figure 2.13. 
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Figure 2.13: Setting the FFT options 

 

 

8. Turn the “Time/Div” knob on the control panel to change the horizontal scale 

(frequency span) of the FFT waveform.  Change the span so that 5 to 10 harmonics are 

visible on the screen.  For example, for an operating frequency of 5 kHz, a total span of 

30 kHz should suffice.  See figure 2.14. 
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Figure 2.14: Setting the FFT options 

 

 

9. Push the “Cursors” button on the control panel to bring up the cursor menu at the 

bottom of the screen.  Under “Active Cursor” toggle until “f1” is highlighted.  Turn the 

cursor knob until the vertical cursor on screen is at the operating frequency (this should 

be the largest peak).  Then toggle the active cursor to “V1”.  Turn the cursor knob until 

the horizontal cursor is at the top of the operating frequency’s peak.  Toggle the active 

cursor to “f2” and move the cursor to the second harmonic.  For an operating frequency 

of 5 kHz, the second harmonic is at 10 kHz.  Toggle the active cursor to “V2” and move 

the cursor to the peak of the second harmonic.  On the screen right below the 

waveform, the value absolute value of ∆V is the difference in dB between the 

fundamental tone and the measured harmonic.  See figure 2.15.  Record this value.  

Leave “f1” and “V1” at the operating frequency and move “f2” and “V2” to the next 

harmonic.  Record its |∆V| in dB.  Repeat for a total of 5 harmonics.   
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Figure 2.15: Using cursors on FFT window for THD measurements 

 

10. Calculate the THD from the measured values of ∆V.  The equation for THD is: 

 

...5432 2222 ++++= HDHDHDHDTHD  

 

2010
nV

HDn

∆−

=  where n = 2,3,4,… and 

 

∆Vn = (Fundamental amplitude in dB) – (nth harmonic amplitude in dB) 

 

11. To plot a screenshot of your waveform to the PC, open the program “HP BenchLink 

Scope”.  Click “Image → 
ew…” then click “Ok” on the window that pops up.  The 

program takes about 5 seconds to copy the oscilloscope window.  See figure 2.16.   To 

save the image, click “File → Save As…” and use the .TIF file extension.   
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Figure 2.16:  HP BenchLink Scope showing captured FFT plots 
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2.4 Measuring Maximum Voltage Swing 
 

Apply a signal to the input of the circuit.   

 

Turn on the oscilloscope by pushing the button at the front of the unit.  Attach the 

channel 1 probe across the input and the channel 2 probe across the output of the circuit.  

Figure 2.3 shows the probes in place on the circuit.  Push the “CH 1 Menu” and “CH 2 

Menu” to turn on the channels for each probe.  Use the “Vertical Position” knobs to align 

the waveforms on the screen.  Use the “Volts/Div” knobs to scale the waveforms so they 

fit on the screen.  Adjust the input until the signal on the oscilloscope is as large as 

possible without clipping.  In figure 2.17, each grid square’s vertical length represents 

500 mV.  So from figure 2.17, we can see the maximum unclipped output waveform is 

1.5 V 0-to-peak. 

 

 

 
Figure 2.17:  HP oscilloscope showing maximum unclipped output waveform 
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2.5 Measuring Input and Output Resistance 
 

Apply a signal to the input using the ELVIS board by clicking on the “Function 

Generator” button.  Make sure the manual mode button on the front of the unit is turned 

off so that all functions of the software function generator are available.  Set the 

frequency of the function generator using the coarse control buttons and then the fine 

tuning knob.  The operating frequency should be exactly 5 kHz.  Select a sinusoidal wave 

type and set the amplitude low enough that there will not be any clipping at the output.  

See figure 2.18.   

 

To measure the input resistance, turn off the power to the circuit, and then attach the 

multimeter probe to the input to measure the AC current.  Switch on the power and 

record the result.  The input current and the input voltage measured from the gain 

calculation combine to give the input resistance by the equation: 

 

in

in

in
i

v
R =  

 

Measure output resistance by removing the load resistor, grounding the circuit input, and 

applying a signal to the output of the circuit.  Measure the AC voltage and AC current at 

the output node to get the output resistance: 
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out

out
i

v
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Figure 2.18:  ELVIS function generator input signal 


